Bug 1786867 - "dnf update dnscrypt-proxy" overwrites dnscrpyt-proxy configuration files in /var/lib/systemd
Summary: "dnf update dnscrypt-proxy" overwrites dnscrpyt-proxy configuration files in ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnscrypt-proxy
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Robert-André Mauchin 🐧
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-28 19:34 UTC by dja26
Modified: 2020-01-19 00:17 UTC (History)
2 users (show)

Fixed In Version: dnscrypt-proxy-2.0.36-2.fc31 dnscrypt-proxy-2.0.36-2.el8
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-12 01:42:06 UTC
Type: Bug


Attachments (Terms of Use)

Description dja26 2019-12-28 19:34:06 UTC
Description of problem:
When using DNF to update dnscrypt-proxy, the update package overwrites the existing /usr/lib/systemd/system/dnscrypt-proxy.socket.  The dnscrypt-proxy rpm package does not see this as a configuration file, though it most definitely has system specific configuration regarding listening interfaces.  Any tailoring to the file (for example specifying listening interfaces) is lost upon update. If the default configuration does not work (for example because the default configuration listens on IPv6, even if IPv6 is disabled), then dnscrypt-proxy.socket will fail to restart.

Version-Release number of selected component (if applicable):  Latest upgrade affected is dnscrypt-proxy 2.0.35 on Fedora 31.

How reproducible: Always occurs


Steps to Reproduce:
1. Install dnscrypt-proxy
2. Tailor configuration in /usr/lib/systemd/system/dnscrypt-proxy.socket (and probably the .service file too, though I haven't tested that)
3. Update dnscrypt-proxy when a new version is available

Actual results:
Tailored configuration in /usr/lib/systemd/system/dnscrypt-proxy.socket is lost, overwritten by the default configuration

Expected results: Existing configuration is preserved, so as to not risk failure to restart the service, or unexpected configuration changes.  New configuration saved as .rpmnew so it's available for manual installation if desired.

Additional info:  Updated to dnscrypt-proxy 2.0.35 this morning.  This is the first time it updated for me since upgrading to Fedora 31.  In Fedora 30 there were no issues.  The update from 30 to 31 also overwrote the file, but at the time I assumed that was due to the OS version upgrade.  Individual package updates should not overwrite the configuration information in the file.

Comment 1 Fedora Update System 2019-12-29 17:03:20 UTC
FEDORA-2019-ccfad28aac has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-ccfad28aac

Comment 2 Fedora Update System 2019-12-29 17:13:24 UTC
FEDORA-EPEL-2019-5718380104 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-5718380104

Comment 3 Fedora Update System 2020-01-04 20:23:48 UTC
dnscrypt-proxy-2.0.36-2.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-5718380104

Comment 4 Fedora Update System 2020-01-04 22:23:44 UTC
dnscrypt-proxy-2.0.36-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-ccfad28aac

Comment 5 dja26 2020-01-05 03:05:15 UTC
Concur that dnscrypt-proxy-2.0.36-2.fc31 resolves the issue for Fedora 31.  Updating to this version does not overwrite the socket file, and rpm shows that the file is marked as a config.

Comment 6 Fedora Update System 2020-01-12 01:42:06 UTC
dnscrypt-proxy-2.0.36-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2020-01-19 00:17:25 UTC
dnscrypt-proxy-2.0.36-2.el8 has been pushed to the Fedora EPEL 8 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.