Bug 178698 - NIS "compat" entries not supported by the "files" and "shadow" modules
NIS "compat" entries not supported by the "files" and "shadow" modules
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: libuser (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-23 11:37 EST by Linus van Geuns
Modified: 2012-06-14 16:26 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 16:26:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (2.00 KB, patch)
2008-04-27 11:01 EDT, ritz
no flags Details | Diff

  None (edit)
Description Linus van Geuns 2006-01-23 11:37:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.12) Gecko/20050921 Red Hat/1.0.7-1.4.1 Firefox/1.0.7

Description of problem:
system-config-users fails to start (via SSH w X11-Forwarding).


Version-Release number of selected component (if applicable):
system-config-users-1.2.27-0.EL4.1

How reproducible:
Always

Steps to Reproduce:
1. login via ssh
2. su -
3. system-config-users
  

Actual Results:  # system-config-users

** (system-config-users.py:15456): WARNING **: entry is incorrectly formatted

(system-config-users.py:15456): GLib-GObject-CRITICAL **: file gvaluearray.c: line 42 (g_value_array_get_nth): assertion `value_array != NULL' failed

** ERROR **: file lib/user.c: line 662 (merge_ent_array_duplicates): should not be reached
aborting...
/usr/share/system-config-users/system-config-users: line 4: 15456 Aborted                 /usr/bin/python2 /usr/share/system-config-users/system-config-users.py

Expected Results:  system-config-users should start..

Additional info:
Comment 1 John Sopko 2006-04-20 14:28:53 EDT
I just ran into this problem. We run NIS and I have my
/etc/nsswitch.conf setup like:

#passwd:     files nis
#shadow:     files nis
passwd:     compat
shadow:     compat
group:      files nis

That is I do not use the redhat default, they are commented
out. I want compat mode so I can use + entries in /etc/passwd.

If you use the default "files nis" entry and remove all
your + entries from /etc/passwd it system-config-users works.
|<:(

Comment 2 Nils Philippsen 2006-04-20 14:33:05 EDT
Mirek, can libuser handle NIS-compat-stype passwd and shadow?
Comment 3 Nils Philippsen 2006-04-20 14:33:51 EDT
s/stype/style/
Comment 4 John Sopko 2006-04-20 14:42:05 EDT
I did a few more test, just one "+" sign line in /etc/passwd causes
the problem. Of course you can not use compat mode then
else you lock yourself out of the system.
Comment 5 Miloslav Trmač 2006-04-20 17:09:11 EDT
This was fixed in libuser-0.53.5 (post-RHEL4).

Linus/John, if you are a RHEL customer and have an active support entitlement,
please contact official Red Hat Support at https://www.redhat.com/apps/support/ to
allow correct prioritization of this issue.
Comment 6 John Sopko 2006-04-20 17:50:10 EDT
I get my updates through our campus satellite server and have no
support contract or resources other then bugzilla.
Comment 7 Nils Philippsen 2006-04-21 03:01:46 EDT
John, in that case you should perhaps contact your computing dept. or whoever
operates that satellite so that they can file a request in that matter. 
Comment 8 RHEL Product and Program Management 2006-09-05 15:46:44 EDT
The component this request has been filed against is not planned for inclusion
in the next update. The decision is based on weighting the priority and number
of requests for a component as well as the impact on the Red Hat Enterprise
Linux user-base: other components are considered having higher priority and the
number of changes we intend to include in update cycles is limited.
Comment 9 RHEL Product and Program Management 2006-09-05 16:00:57 EDT
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request. 
Comment 11 ritz 2008-04-27 11:01:12 EDT
Created attachment 303917 [details]
patch 

based on upstream code. this also fixes a memory leak

from libuser-0.53.7/ChangeLog 
2005-04-15  Miloslav Trmac  <mitr@redhat.com>
...
	* modules/files.c (lu_files_enumerate) 
	(lu_files_users_enumerate_by_group) 
	(lu_files_groups_enumerate_by_user, lu_files_enumerate_full): Skip
	nss_compat lines (starting with '+' or '-').
Comment 14 RHEL Product and Program Management 2008-10-31 12:41:13 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 16 RHEL Product and Program Management 2010-10-22 14:53:08 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 17 Jeremy West 2012-06-14 16:26:41 EDT
This bug is being closed now that RHEL4 has entered a limited maintanence phase.  If you're a customer with ELS entitlements and need to have this fixed, please contact our support team by visiting access.redhat.com

Thanks

Note You need to log in before you can comment on or make changes to this bug.