Bug 1787096 - Sorting by 'Starting Deadlines Seconds' don't work on CronJob list page
Summary: Sorting by 'Starting Deadlines Seconds' don't work on CronJob list page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: David Taylor
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-31 02:21 UTC by Yadan Pei
Modified: 2020-05-04 11:22 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: On CronJobs list page, sort by 'Starting Deadlines Seconds' or 'Concurrency Policy' field Consequence: Records are not sorted at all Fix: updated 'sortField' for the two fields Result: You can now sort 'Starting Deadlines Seconds' and 'Concurrency Policy' columns on CronJobs list page.
Clone Of:
Environment:
Last Closed: 2020-05-04 11:21:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3914 None closed Bug 1787096: Sorting by 'Starting Deadlines Seconds' don't work on CronJob list page 2020-04-20 15:31:20 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:22:08 UTC

Description Yadan Pei 2019-12-31 02:21:58 UTC
Description of problem:
When try to sort by 'Starting Deadlines Seconds' on CronJobs list page, the records are not sorted at all

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-12-29-173422

How reproducible:
Always

Steps to Reproduce:
1. Create two CronJobs with different startingDeadlineSeconds
apiVersion: batch/v1beta1
kind: CronJob
metadata:
  name: example1
  namespace: yapei1-project1
spec:
  schedule: '@daily'
  startingDeadlineSeconds: 100
  jobTemplate:
    spec:
      template:
        spec:
          containers:
            - name: hello
              image: busybox
              args:
                - /bin/sh
                - '-c'
                - date; echo Hello from the Kubernetes cluster
          restartPolicy: OnFailure
apiVersion: batch/v1beta1
kind: CronJob
metadata:
  name: example2
  namespace: yapei1-project1
spec:
  schedule: '@daily'
  startingDeadlineSeconds: 300
  jobTemplate:
    spec:
      template:
        spec:
          containers:
            - name: hello
              image: busybox
              args:
                - /bin/sh
                - '-c'
                - date; echo Hello from the Kubernetes cluster
          restartPolicy: OnFailure
2. Goes to CronJobs list page and sort by 'Starting Deadlines Seconds' field


Actual results:
2. CronJobs are not sorted and the sequence is not changed

Expected results:
2. CronJobs should be sorted 

Additional info:

Comment 3 Yadan Pei 2020-01-13 03:00:54 UTC
1) Create two CronJobs with different value of concurrencyPolicy && startingDeadlineSeconds
2) then goto CronJobs page and sort by 'Concurrency Policy' and 'Starting Deadline Seconds'

now the sorting on these two fields work, verified on 4.4.0-0.nightly-2020-01-12-221811

Comment 5 errata-xmlrpc 2020-05-04 11:21:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.