Bug 178716 - RFE - Add support for the HP DeviceURI
RFE - Add support for the HP DeviceURI
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-23 13:46 EST by David Hollis
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-24 12:19:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Hollis 2006-01-23 13:46:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
With HPLIP, an 'hp' backend is available for CUPS to provide better support for HP  inkjets/multifunctions.  I have an OfficeJet 7210 multi-function which I can setup fine with s-c-p for printing, but I can not use the HP toolbox to get better support for the device (scanning, ink levels, etc).  If I use the 'hp-makeuri' command, it spits out a CUPS DeviceURI that I can then use with /etc/cups/printers.conf to get this support.  Unfortunately, if foomatic (or anything else that rebuilds the printers.conf) gets updated/installed, I'm back to a socket DeviceURI.  It looks to me like all that might be needed is a bit of code in utils/backend.py in the device_uri() subroutine, but I'm not a python guy and haven't figured out how all of the printer configuration is stored in the system.

For an idea of what the HP DeviceURI looks like:

[dhollis@dhollis-lnx ~]$ hp-makeuri 172.16.9.3

 HP Linux Imaging and Printing System (ver. 0.9.7)
 Device URI Creation Utility ver. 2.5

 Copyright (c) 2003-5 Hewlett-Packard Development Company, LP
 This software comes with ABSOLUTELY NO WARRANTY.
 This is free software, and you are welcome to distribute it
 under certain conditions. See COPYING file for more details.

 Creating URIs for '172.16.9.3':
CUPS URI: hp:/net/Officejet_7200_series?ip=172.16.9.3
SANE URI: hpaio:/net/Officejet_7200_series?ip=172.16.9.3

[dhollis@dhollis-lnx ~]$


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install HP inkjet or multi-function printer
2. Configure with s-c-p as JetDirect
3. Change the DeviceURI to the HP backend
4. /usr/sbin/printconf-backend --force-rebuild
5. DeviceURI is now back to socket://x.x.x.x
  

Additional info:
Comment 1 Tim Waugh 2006-01-23 17:58:24 EST
You've reported this against 'devel' -- but are you really running rawhide? 
What does 'rpm -q system-config-printer' say?
Comment 2 David Hollis 2006-01-24 09:47:36 EST
[dhollis@dhollis-lnx ~]$ rpm -q system-config-printer
system-config-printer-0.6.149-1
Comment 3 Tim Waugh 2006-01-24 12:19:39 EST
Oh, are you actually editing an entry in the printers.conf file that
system-config-printer created?  You can't do that -- make a new queue using
http://localhost:631/ instead.

Note You need to log in before you can comment on or make changes to this bug.