Bug 17873 - Xsetup_0 misses kdmdesktop!
Summary: Xsetup_0 misses kdmdesktop!
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xinitrc (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-26 19:37 UTC by Sammy
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-03 15:37:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sammy 2000-09-26 19:37:17 UTC
Somehow the pidof statement is missing the kdm and branching to
a xsetroot command with solid background. I am running kdm and
upto 7.0 kdmdesktop always ran. I just commented the xsetroot
and put in kdmdesktop in the second branch and now I get my nicer
background....FYI

Comment 1 Ian Pilcher 2000-10-03 15:37:20 UTC
This is happening because kdm has been patched to update the PATHs for root and
normal users.  The patch omits /sbin and /usr/sbin from root's PATH, so Xsetup_0
can't find /sbin/pidof.

Changing Xsetup_0 to explicitly reference /sbin/pidof fixes this problem.

(Personally, I question the necessity of patching the PATHs in kdm at all.  I
suspect that it was done as a workaround for the fact that users are not
properly logged on when kdm is used.  However, this is caused by a change to
Xsession, and I believe that it should be addressed there.)

Comment 2 Ngo Than 2000-10-11 13:50:55 UTC
This problem is fixed in xinitrc-3.1-1


Note You need to log in before you can comment on or make changes to this bug.