Bug 178741 - yum localupdate with exclude list doesn't work as expected
yum localupdate with exclude list doesn't work as expected
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-23 17:08 EST by Gianluca Cecchi
Modified: 2014-01-21 17:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-20 15:20:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gianluca Cecchi 2006-01-23 17:08:34 EST
Description of problem:
It seems that yum with "localupdate" command parameter doesn't support exclude lists

Version-Release number of selected component (if applicable):
yum-2.5.1-2

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

I take the occasion form these days situation where for dependency conflict, I
cannot upgrade totem, because rythmbox requires a minor version of a library
provided with totem itself.
All other packages installed on my system are syncronized with mirrors.
I have also a local directory with all updated rpms in it, rsynced.
Here below some commands and comments:
1) yum update
gives dependency error

2) yum update --exclude=totem\*
ok.

3) yum localupdate *rpm
gives dependency error

4) yum localupdate *rpm --exclude=totem\*
Same as 3). It gives message:
Excluding Packages in global exclude list
but it seems it doesn't use it actually.
The same if I give: yum localupdate --exclude=totem\* *rpm

BTW: note also that for "localupdate" in 3) and 4) it tries to install kernel
that is already installed on the system, while in "update" mode it is ok.

See below extended output.

1)
[root@fedora ~]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
extras-dev: ################################################## 2/2
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for totem to pack into transaction set.
totem-1.3.1-1.i386.rpm    100% |=========================|  34 kB    00:00
---> Package totem.i386 0:1.3.1-1 set to be updated
--> Running transaction check
--> Processing Dependency: libtotem-plparser.so.0 for package: rhythmbox
--> Finished Dependency Resolution
Error: Missing Dependency: libtotem-plparser.so.0 is needed by package rhythmbox

2)
[root@fedora ~]# yum update --exclude=totem\*
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
extras-dev: ################################################## 2/2
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
No Packages marked for Update/Obsoletion

3)
[root@fedora ~]# yum localupdate *rpm
[snip]
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kernel-smp.i686 0:2.6.15-1.1869_FC5 set to be installed
---> Package totem.i386 0:1.3.1-1 set to be updated
---> Package kernel.i686 0:2.6.15-1.1869_FC5 set to be installed
--> Running transaction check
Setting up repositories
extras-dev: ################################################## 2/2
Reading repository metadata in from local files
--> Processing Dependency: libtotem-plparser.so.0 for package: rhythmbox
--> Finished Dependency Resolution
Error: Missing Dependency: libtotem-plparser.so.0 is needed by package rhythmbox

4)
[root@fedora ~]# yum localupdate *rpm --exclude=totem\*
[snip]
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kernel-smp.i686 0:2.6.15-1.1869_FC5 set to be installed
---> Package totem.i386 0:1.3.1-1 set to be updated
---> Package kernel.i686 0:2.6.15-1.1869_FC5 set to be installed
--> Running transaction check
Setting up repositories
extras-dev: ################################################## 2/2
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
--> Processing Dependency: libtotem-plparser.so.0 for package: rhythmbox
--> Finished Dependency Resolution
Error: Missing Dependency: libtotem-plparser.so.0 is needed by package rhythmbox
Comment 1 Rahul Sundaram 2006-02-20 06:15:09 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Jeremy Katz 2006-04-19 16:36:19 EDT
Does this work better with fc5 final?
Comment 3 Gianluca Cecchi 2006-04-20 00:48:15 EDT
It doesn't seem so.
In my fc5 final yum is yum-2.6.0-1.
I create a test dir where I put gdm-2.14.1-1.fc5.2.i386.rpm and
util-linux-2.13-0.20.1.i386.rpm, that right now need upgrade.
Then I put myself in test dir
My installed version are: gdm-2.14.0-1 and util-linux-2.13-0.20

1)
[root@fedora test]# yum update gdm util-linux --exclude=gdm
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
core                                                                 [1/3]
extras                                                               [2/3]
updates                                                              [3/3]
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Could not find update match for gdm
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package util-linux.i386 0:2.13-0.20.1 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 util-linux              i386       2.13-0.20.1      updates           1.9 M

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       1 Package(s)
Remove       0 Package(s)
Total download size: 1.9 M
Is this ok [y/N]:

2) 
[root@fedora test]# yum localupdate *rpm --exclude=gdm
Loading "installonlyn" plugin
Setting up Local Package Process
Examining gdm-2.14.1-1.fc5.2.i386.rpm: gdm - 1:2.14.1-1.fc5.2.i386
Examining util-linux-2.13-0.20.1.i386.rpm: util-linux - 2.13-0.20.1.i386
Marking gdm-2.14.1-1.fc5.2.i386.rpm as an update to gdm - 1:2.14.0-1.i386
Marking util-linux-2.13-0.20.1.i386.rpm as an update to util-linux - 2.13-0.20.i386
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package gdm.i386 1:2.14.1-1.fc5.2 set to be updated
---> Package util-linux.i386 0:2.13-0.20.1 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 gdm                     i386       1:2.14.1-1.fc5.2 
gdm-2.14.1-1.fc5.2.i386.rpm  9.9 M
 util-linux              i386       2.13-0.20.1     
util-linux-2.13-0.20.1.i386.rpm  4.5 M

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       2 Package(s)
Remove       0 Package(s)
Total download size: 14 M
Is this ok [y/N]:

The same with:  
yum localupdate *rpm --exclude=gdm\*
yum localupdate *rpm --exclude=gdm*
yum localupdate *rpm --exclude=gdm-2.14.1-1.fc5.2.i386.rpm

So now it seems that
"Excluding Packages in global exclude list" sentence
is neither considered.....
Note also that if I do

3)
[root@fedora test]# yum update *rpm --exclude=gdm
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
core                                                                 [1/3]
extras                                                               [2/3]
updates                                                              [3/3]
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Examining gdm-2.14.1-1.fc5.2.i386.rpm: gdm - 1:2.14.1-1.fc5.2.i386
Examining util-linux-2.13-0.20.1.i386.rpm: util-linux - 2.13-0.20.1.i386
Marking gdm-2.14.1-1.fc5.2.i386.rpm as an update to gdm - 1:2.14.0-1.i386
Marking util-linux-2.13-0.20.1.i386.rpm as an update to util-linux - 2.13-0.20.i386
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package gdm.i386 1:2.14.1-1.fc5.2 set to be updated
---> Package util-linux.i386 0:2.13-0.20.1 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 gdm                     i386       1:2.14.1-1.fc5.2 
gdm-2.14.1-1.fc5.2.i386.rpm  9.9 M
 util-linux              i386       2.13-0.20.1     
util-linux-2.13-0.20.1.i386.rpm  4.5 M

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       2 Package(s)
Remove       0 Package(s)
Total download size: 14 M
Is this ok [y/N]:


Comment 4 Jeremy Katz 2006-04-20 15:20:37 EDT
Fixed in upstream CVS for yum-2.6.1 (... assuming Seth doesn't kill me ;-)

Note You need to log in before you can comment on or make changes to this bug.