Bug 1787445 - /etc/passwd misconfigured in ansible-operator base image
Summary: /etc/passwd misconfigured in ansible-operator base image
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Operator SDK
Version: 4.2.z
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.2.z
Assignee: Joe Lanford
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On: 1787587
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-02 21:10 UTC by Fabian von Feilitzsch
Modified: 2020-01-22 10:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1787587 (view as bug list)
Environment:
Last Closed: 2020-01-22 10:46:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift ocp-release-operator-sdk pull 33 None closed Bug 1787445: [release-4.2] Run user_setup script in builds 2020-02-05 15:07:41 UTC
Red Hat Product Errata RHBA-2020:0107 None None None 2020-01-22 10:46:57 UTC

Description Fabian von Feilitzsch 2020-01-02 21:10:23 UTC
Description of problem:
/etc/passwd not properly configured on Ansible Operator base image

When we moved away from allowing CRI-O to handle builds, it looks like we didn't re-enable the user_setup script, which sets the permissions on /etc/passwd to prevent CRI-O from attempting to write to set it up.



Version-Release number of selected component (if applicable):
4.2.z

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
This also blocks all tests for the 4.2 Ansible Operator base image.

Comment 1 Fabian von Feilitzsch 2020-01-03 20:15:06 UTC
How reproducible:
100%

Steps to Reproduce:
1. Start any Ansible-based operator

Actual results:
It crashes do to permissions errors

Expected results:
It starts successfully

Comment 3 Fan Jia 2020-01-13 06:47:21 UTC
test result:

operator-sdk version: branch release 4.2  50b14bf4-dirty, commit: 50b14bf4705450bac99cc70730865c405be30567

generate one ansible operator "memcached" and run in 4.2 cluster success
#oc get deployment
NAME                 READY   UP-TO-DATE   AVAILABLE   AGE
memcached-operator   1/1     1            1           3m47s
#oc get pods
NAME                                          READY   STATUS    RESTARTS   AGE
example-memcached-memcached-7db5f499d-c779w   1/1     Running   0          88s
example-memcached-memcached-7db5f499d-djjvj   1/1     Running   0          88s
example-memcached-memcached-7db5f499d-tbtxf   1/1     Running   0          88s
memcached-operator-f78969fdd-74lsh            2/2     Running   0          2m34s

Comment 5 errata-xmlrpc 2020-01-22 10:46:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0107


Note You need to log in before you can comment on or make changes to this bug.