Bug 178746 - avahi-dnsconfd initscript erroneous, fails to start
Summary: avahi-dnsconfd initscript erroneous, fails to start
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: avahi   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-23 23:04 UTC by Kai Thomsen
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-21 02:19:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch for the initscript. (538 bytes, patch)
2006-01-23 23:12 UTC, Kai Thomsen
no flags Details | Diff
A patch for the avahi-dnsconfd initscript of avahi-0.6.6-2. (1.19 KB, patch)
2006-02-10 00:33 UTC, Kai Thomsen
no flags Details | Diff

Description Kai Thomsen 2006-01-23 23:04:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
Starting the avahi-dnsconfd initscript fails, although avahi-daemon is running. The cause is a missing ";;" inside a case statement.

Besides, the avahi-dnsconfd service is not "visible" to tools such as chkconfig or system-config-services because its initscript wrongly states "avahi-daemon" as the service name, which is (not surprisingly) already used for the avahi-daemon itself.

Version-Release number of selected component (if applicable):
avahi-0.6.4-3

How reproducible:
Always

Steps to Reproduce:
1. Make sure avahi-daemon is running.
2. service avahi-dnsconfd start


Actual Results:  The initscript errors out without starting avahi-dnsconfd.

Expected Results:  avahi-dnsconfd should have been started successfully.

Additional info:

# service avahi-daemon status
Avahi daemon is running
# service avahi-dnsconfd start
/etc/init.d/avahi-dnsconfd: line 91: syntax error near unexpected token `)'
/etc/init.d/avahi-dnsconfd: line 91: `  *)'
#

Comment 1 Kai Thomsen 2006-01-23 23:12:09 UTC
Created attachment 123596 [details]
A patch for the initscript.

Comment 2 Kai Thomsen 2006-01-23 23:52:36 UTC
Sorry, apparently I was wrong as to the reason for the "invisibility" of the
avahi-dnsconfd service: The initscript simply isn't "chkconfig --add"ed in the
RPM package's post-install scriptlet yet.

Comment 3 Jason Vas Dias 2006-01-24 00:16:57 UTC
OK, fixed with avahi-0.6.4-4 in rawhide-20060124 / FC-5t3 . 


Comment 4 Kai Thomsen 2006-02-10 00:29:22 UTC
The patch below contains some more (mainly minor) corrections to the 
initscript. A different lockfile name is given so that it doesn't collide with 
avahi-daemon. Just some suggestions for an overhaul... :) I realize the 
initscript is not used by default yet (avahi-0.6.6-2).


Comment 5 Kai Thomsen 2006-02-10 00:33:58 UTC
Created attachment 124466 [details]
A patch for the avahi-dnsconfd initscript of avahi-0.6.6-2.

Comment 6 Ville Skyttä 2006-02-12 20:35:21 UTC
avahi-dnsconfd is still not "chkconfig --add"ed in 0.6.6-3.1 (see comment 2).

Comment 7 Kai Thomsen 2006-09-21 02:19:30 UTC
Re comment 6:

This has been fixed in the meantime (I've looked at 0.6.10-1.FC5).


Note You need to log in before you can comment on or make changes to this bug.