Bug 178748 - Several gawk/awk denied execmod
Several gawk/awk denied execmod
Status: CLOSED DUPLICATE of bug 178747
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-23 18:41 EST by Émeric Maschino
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-27 00:53:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Émeric Maschino 2006-01-23 18:41:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ia64; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
At bootup in permissive mode, I'm getting the following messages that are also recorded in /var/log/messages:

Jan 24 01:12:21 zx6000 kernel: audit(1138061500.468:3): avc:  denied  { execmod
} for  pid=391 comm="awk" name="gawk" dev=dm-0 ino=3371818 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:bin_t:s0 tclass=file

Jan 24 01:12:21 zx6000 kernel: audit(1138061501.284:5): avc:  denied  { execmod
} for  pid=415 comm="awk" name="gawk" dev=dm-0 ino=3371818 scontext=system_u:system_r:udev_t:s0-s0:c0.c255 tcontext=system_u:object_r:bin_t:s0 tclass=file

Jan 24 01:12:24 zx6000 kernel: audit(1138061532.848:13): avc:  denied  { execmod } for  pid=1817 comm="awk" name="gawk" dev=dm-0 ino=3371818 scontext=system_u:system_r:dhcpc_t:s0 tcontext=system_u:object_r:bin_t:s0 tclass=file

Touch /.autorelabel doesn't solve the problem. I don't know when this problem appears. I'm running Fedora Core since January 10th only and these messages were already there.

Version-Release number of selected component (if applicable):
selinux-policy-targeted 2.2.2-1, gawk 3.1.5-5

How reproducible:
Always

Steps to Reproduce:
1. Boot up Fedora Core IA-64 devel
2.
3.
  

Additional info:
Comment 1 Daniel Walsh 2006-01-27 00:53:03 EST

*** This bug has been marked as a duplicate of 178747 ***

Note You need to log in before you can comment on or make changes to this bug.