Bug 1787492 - error message is not clear when user tries to search and deploy from private image
Summary: error message is not clear when user tries to search and deploy from private ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.4.0
Assignee: Karthik Jeeyar
QA Contact: Ruchir Garg
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-03 05:43 UTC by Yadan Pei
Modified: 2020-05-04 11:22 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Improve the error message on the internal registry feature Reason: If there is any server side error, then it has to be properly notified to the user to help them understand the problem better. Result: Helps the user to identify the problem happened during the submission of the request.
Clone Of:
Environment:
Last Closed: 2020-05-04 11:22:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4073 None closed Bug 1787492: fix(deployimage-status) fix external registry error message 2020-04-24 19:11:03 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:22:46 UTC

Description Yadan Pei 2020-01-03 05:43:14 UTC
Description of problem:
When user tries to search private image and deploy app from it, the first time we click search button gives unclear error message 

Version-Release number of selected component (if applicable):
    4.3.0-0.nightly-2020-01-02-214950

How reproducible:
Always

Steps to Reproduce:
1. Switch to Developer Console -> +Add -> Container Image -> yapei/wordpress, click on Search button
2. Click Search button again

Actual results:
1. It shows this error message on the first search
 Could not load image metadata. 
         Required
2. On the second search, it shows 
Could not load image metadata.

you may not have access to the container image "docker.io/yapei/wordpress:latest"

Expected results:
1. It should show 'you may not have access to the container image "docker.io/yapei/wordpress:latest' even at the first search, the first message seems useless


Additional info:

Comment 1 cvogt 2020-01-06 16:51:19 UTC
Jira tracker: https://issues.redhat.com/browse/ODC-2677

Comment 3 Vikram Raj 2020-02-06 10:24:58 UTC
This bug has been fixed I validated it on

Cluster: 4.4.0-0.ci-2020-02-05-054333
Brower: Firefox(71.0), Chrome (79.0.3945.79)
User: Admin and consoledeveloper

Comment 5 errata-xmlrpc 2020-05-04 11:22:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.