Bug 178751 - rhgb-client denied execmod
rhgb-client denied execmod
Status: CLOSED DUPLICATE of bug 178747
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-23 18:58 EST by Émeric Maschino
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-26 15:45:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requested audit.log file (17.59 KB, text/x-log)
2006-01-25 20:36 EST, Émeric Maschino
no flags Details
Output of strace -i /usr/bin/rhgb-client (7.74 KB, application/octet-stream)
2006-01-25 20:37 EST, Émeric Maschino
no flags Details

  None (edit)
Description Émeric Maschino 2006-01-23 18:58:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ia64; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
When booting in permissive mode, the following message is recorded in /var/log/messages:

Jan 24 01:12:23 zx6000 kernel: audit(1138061526.380:8): avc:  denied  { execmod
} for  pid=1540 comm="rhgb-client" name="rhgb-client" dev=dm-0 ino=10353752 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:bin_t:s0 tclass=file

touch /.autorelabel didn't help. I don't know when this problem appears (I'm only running Fedora Core since January 10th and don't remember if the problem was already there).

Version-Release number of selected component (if applicable):
selinux-policy-targeted 2.2.2-1, rhgb 0.16.2-20

How reproducible:
Always

Steps to Reproduce:
1. Boot up Fedora Core IA-64 devel in permissive mode
2.
3.
  

Additional info:
Comment 1 Daniel Walsh 2006-01-25 10:11:40 EST
Could you attach the entire audit.log file.

Also could you strace -i an executable that is creating this avc message and
attach the output to it.

Comment 2 Émeric Maschino 2006-01-25 20:35:39 EST
(In reply to comment #1)

Hello Daniel,

> Could you attach the entire audit.log file.

Sure. Please find it in attached. You'll also find the other AVC messages I've
already reported.

> Also could you strace -i an executable that is creating this avc message and
> attach the output to it.

As requested, I've attached the output of strace -i /usr/bin/rhgb-client. If
this isn't the right way to produce the needed output, please let me know.
Comment 3 Émeric Maschino 2006-01-25 20:36:40 EST
Created attachment 123702 [details]
Requested audit.log file
Comment 4 Émeric Maschino 2006-01-25 20:37:43 EST
Created attachment 123703 [details]
Output of strace -i /usr/bin/rhgb-client
Comment 5 Daniel Walsh 2006-01-26 15:45:50 EST

*** This bug has been marked as a duplicate of 178747 ***

Note You need to log in before you can comment on or make changes to this bug.