Bug 1787512 - gnome-software is trying to access network connection in the background
Summary: gnome-software is trying to access network connection in the background
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-software
Version: 7.6
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Richard Hughes
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-03 08:36 UTC by jajeon
Modified: 2021-01-22 02:53 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-27 15:41:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME/gnome-software - issues 748 0 None None None 2020-06-22 13:24:52 UTC
Red Hat Knowledge Base (Solution) 4713491 0 None None None 2020-01-06 05:40:34 UTC

Description jajeon 2020-01-03 08:36:06 UTC
Description of problem:

gnome-software is trying to access network connections in the background.
"
$ grep 'gnome.org' journalctl_--no-pager_--catalog_--boot |tail -4
Dec 09 06:44:56 bliqmdb2 gnome-software[217458]: failed to call gs_plugin_refresh on shell-extensions: [*/*/*/source/shell-extensions/*] failed to download https://extensions.gnome.org//static/extensions.json: Connection terminated unexpectedly
Dec 09 06:45:16 bliqmdb2 gnome-software[217458]: failed to call gs_plugin_refresh on odrs: [*/*/*/source/odrs/*] failed to download https://odrs.gnome.org/1.0/reviews/api/ratings: Connection terminated unexpectedly
Dec 10 06:44:56 bliqmdb2 gnome-software[217458]: failed to call gs_plugin_refresh on shell-extensions: [*/*/*/source/shell-extensions/*] failed to download https://extensions.gnome.org//static/extensions.json: Connection terminated unexpectedly
Dec 10 06:45:16 bliqmdb2 gnome-software[217458]: failed to call gs_plugin_refresh on odrs: [*/*/*/source/odrs/*] failed to download https://odrs.gnome.org/1.0/reviews/api/ratings: Connection terminated unexpectedly
"

Currently only way to suppress this error message is:
1. disable gnome software start
"
/etc/xdg/autostart/gnome-software-service.desktop
[Desktop Entry]
... ...
X-GNOME-Autostart-enabled = false 	
"

2. mask packagekit service
systemctl mask packagekit.service



Version-Release number of selected component (if applicable):
This issue was confirmed from RHEL7.6, however this problem exists even before.


How reproducible:
Issue can be reproduced on the system where outside network is not allowed


Expected results:
gnome-software should not option to disable network connection in the background

Additional info:

It looks like gnome has no option to disable this.
https://gitlab.gnome.org/GNOME/gnome-software/issues/748

Comment 3 Richard Hughes 2020-02-11 13:48:17 UTC
This is the gnome shell extensions website where we download a catalog of extensions to show in search results. You can delete the /usr/lib64/gs-plugins-*/libgs_plugin_shell-extensions.so if you would like to disable this functionality. Upstream this feature has moved to GNOME Shell and is no longer part of gnome-software.

Comment 4 jajeon 2020-03-05 00:00:01 UTC
what could be the side effect of deleting library file?

Also, majority of customers who is using RHEL does not allow internet connection.
Why consider to disable as default and enable it as user really need it?

Comment 6 Richard Hughes 2020-07-01 09:07:15 UTC
> what could be the side effect of deleting library file?

For the ODRS, the per-app ratings and review functionality will be unavailable. For shell-extensions, the non-installed GNOME shell extensions will not show.

> Why consider to disable as default and enable it as user really need it

Upstream in GNOME there's not really a "make everything configurable" mentality. For RHEL we could add configuration, but it's not something I'm super enthusiastic about.

Comment 9 Tomas Popela 2020-08-27 14:42:37 UTC
Closing the bug as the attached customer case is closed.


Note You need to log in before you can comment on or make changes to this bug.