Bug 178766 - fbdev ghost tails on drag
fbdev ghost tails on drag
Status: CLOSED DUPLICATE of bug 178433
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-fbdev (Show other bugs)
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Depends On:
  Show dependency treegraph
Reported: 2006-01-23 23:43 EST by John Reiser
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-01-25 15:56:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
screenshot showing bad display after dragging window (286.83 KB, image/png)
2006-01-23 23:45 EST, John Reiser
no flags Details
xorg.conf (2.62 KB, text/plain)
2006-01-23 23:47 EST, John Reiser
no flags Details
/var/log/Xorg.0.log (41.47 KB, text/plain)
2006-01-23 23:48 EST, John Reiser
no flags Details

  None (edit)
Description John Reiser 2006-01-23 23:43:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
Under Fedora Core 5 test 2 on Apple Macintosh Mini (PowerPC 32-bit), dragging a window does not restore the background on the trailing horizontal edge.  The trailing vertical edge is OK.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Drag a window (move the pointer to the title bar, press and hold Button1, move the mouse.)

Actual Results:  The trailing horizontal edge leaves "ghost tails" instead of restoring the newly-exposed background window.

Expected Results:  The trailing horizontal edge should redraw the newly-exposed background window.

Additional info:

Will attach xorg.conf (created by anaconda) and Xorg.0.log.
Comment 1 John Reiser 2006-01-23 23:45:09 EST
Created attachment 123597 [details]
screenshot showing bad display after dragging window
Comment 2 John Reiser 2006-01-23 23:47:32 EST
Created attachment 123598 [details]

Note line in Section "Device":
	Option	    "UseFBDev" "true"
Comment 3 John Reiser 2006-01-23 23:48:34 EST
Created attachment 123599 [details]
Comment 4 John Reiser 2006-01-23 23:55:14 EST
The badness happens only when the Desktop is the background window.  Application
windows (at least: gnome-terminal, Firefox) that are exposed by drag get
[re-]drawn properly.
Comment 5 Frank Arnold 2006-01-25 07:55:40 EST
Please try adding the following line to the Device section of your

Option "AccelMethod" "EXA"

It might be related to this Xorg bug:

Comment 6 John Reiser 2006-01-25 14:59:32 EST
Thank you, Frank.  That works.  The Desktop (root window) is redrawn properly on
the trailing horizontal edge of another window being dragged.

The complete Device section is now:
Section "Device"
        Identifier  "Videocard0"
        Driver      "ati"
        VendorName  "Videocard vendor"
        BoardName   "ATI Technologies Inc RV280 [Radeon 9200]"
        Option      "UseFBDev" "true"
        Option      "AccelMethod" "EXA"
Comment 7 Rahul Sundaram 2006-01-25 15:56:38 EST
Thank you for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.

*** This bug has been marked as a duplicate of 178433 ***

Note You need to log in before you can comment on or make changes to this bug.