Bug 1787739 - spamassassin update ends up with configuration files from a wrong version
Summary: spamassassin update ends up with configuration files from a wrong version
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: spamassassin
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1787934 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-04 21:29 UTC by Michal Jaegermann
Modified: 2020-01-13 01:21 UTC (History)
5 users (show)

Fixed In Version: spamassassin-3.4.3-2.fc31 spamassassin-3.4.3-2.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-07 01:57:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Michal Jaegermann 2020-01-04 21:29:09 UTC
Description of problem:

Right after an update the multiple lines like that show up in logs:

.... config: configuration file "/usr/share/spamassassin/20_advance_fee.cf" requires version 3.004002 of SpamAssassin, but this is code version 3.004003. Maybe you need to use the -C switch, or remove the old config files? Skipping this file at /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Conf/Parser.pm line 408

and so on

Indeed, running  'grep -r require_version /usr/share/spamassassin' gives:


/usr/share/spamassassin/20_dnsbl_tests.cf:require_version 3.004002
/usr/share/spamassassin/20_meta_tests.cf:require_version 3.004002
/usr/share/spamassassin/20_phrases.cf:require_version 3.004002
/usr/share/spamassassin/20_compensate.cf:require_version 3.004002
/usr/share/spamassassin/20_net_tests.cf:require_version 3.004002
/usr/share/spamassassin/72_active.cf:require_version 3.004002
/usr/share/spamassassin/23_bayes.cf:require_version 3.004002
/usr/share/spamassassin/73_sandbox_manual_scores.cf:require_version 3.004002
/usr/share/spamassassin/20_dynrdns.cf:require_version 3.004002
/usr/share/spamassassin/20_uri_tests.cf:require_version 3.004002
/usr/share/spamassassin/20_advance_fee.cf:require_version 3.004002
/usr/share/spamassassin/20_head_tests.cf:require_version 3.004002
/usr/share/spamassassin/20_html_tests.cf:require_version 3.004002
/usr/share/spamassassin/20_porn.cf:require_version 3.004002
/usr/share/spamassassin/20_drugs.cf:require_version 3.004002
/usr/share/spamassassin/20_fake_helo_tests.cf:require_version 3.004002
/usr/share/spamassassin/20_body_tests.cf:require_version 3.004002

despite all these files belonging to spamassassin-3.4.3-1.fc31 package.

Version-Release number of selected component (if applicable):
spamassassin-3.4.3-1.fc31

Additional info:
Manually running 'sa-update' seems to help.  Well, files from /var/lib/spamassassin/3.004003/updates_spamassassin_org/ have 'require_version 3.004003'.

Comment 1 Kevin Fenzi 2020-01-04 22:21:34 UTC
Ugh, yes. The rules files are correct, but the version passed into them is wrong. ;( 

I'll push out an update, but the quick fix as you see is to just pull updates... but we should fix it for initial runs and people who can't easily update.

Comment 2 Fedora Update System 2020-01-04 23:14:47 UTC
FEDORA-2020-88f675dd34 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-88f675dd34

Comment 3 Fedora Update System 2020-01-05 01:27:01 UTC
spamassassin-3.4.3-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-88f675dd34

Comment 4 Fedora Update System 2020-01-05 02:27:05 UTC
spamassassin-3.4.3-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-54435b80e0

Comment 5 Kevin Fenzi 2020-01-05 18:23:34 UTC
*** Bug 1787934 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2020-01-07 01:57:53 UTC
spamassassin-3.4.3-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2020-01-13 01:21:46 UTC
spamassassin-3.4.3-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.