Bug 178780 - hibernate fails swsusp: Cannot find swap device, try swapon -a.
hibernate fails swsusp: Cannot find swap device, try swapon -a.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-24 07:15 EST by Neal Becker
Modified: 2015-01-04 17:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-02 03:07:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2006-01-24 07:15:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.0 (like Gecko)

Description of problem:
pm-hibernate fails with:  
 swsusp: Cannot find swap device, try swapon -a. 
 
Of course, I have swap, and pm-suspend was working a couple of kernels ago: 
 
cat /proc/swaps  
Filename				Type		Size	Used	
Priority 
/dev/mapper/VolGroup00-LogVol01         partition	2031608	0	-1 
 
Perhaps relevant, swap is on lvm.  This is default partitioning setup by 
anaconda. 

Version-Release number of selected component (if applicable):
2.6.15-1.1869_FC5

How reproducible:
Always

Steps to Reproduce:
1.pm-hibernate 
2. 
3. 
   

Additional info:
Comment 1 Rahul Sundaram 2006-02-20 05:45:51 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Dave Jones 2006-03-02 03:07:07 EST
this was an upstream regression that has now been fixed.
reopen if it reoccurs.

Note You need to log in before you can comment on or make changes to this bug.