Bug 17879 - linuxconf + RH scripts create Class A routing error
linuxconf + RH scripts create Class A routing error
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-26 16:50 EDT by whit
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-01 15:55:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description whit 2000-09-26 16:50:28 EDT
On a machine on a DSL line on an 64.* subnet with a mask of
255.255.255.248, set up through linuxconf, a spurious line shows up in the
routing table that disables any attempt to connect to any outside site in
the 64.*.*.* Class A:

64.0.0.0        *               255.0.0.0       U         0 0          0
eth0

If I do an 'ifconfig etho down' and then 'ifconfig eth0 up' that line
returns! Please, where do I disable this 'feature'! This is not anything
I've entered anywhere, but some artifact of linuxconf + Redhat's scripts.
Nor does 'route del 64.0.0.0' work to clear this bad entry. I guess some
script is confused, but not sure where the error lives.

BTW, it would be nice if RH produced a guide to doing configuration
_without_ problematic utilities like linuxconf - step by step guides to
doing configuration by hand, and to disabling scripts when they disable
good operations.
Comment 1 Pekka Savola 2000-09-30 16:14:17 EDT
Check that NETMASK is defined right in /etc/sysconfig/network-scripts/ifcfg-eth0.
NETWORK need not be defined, but if it is, check it too.
Comment 2 whit 2000-10-01 15:55:32 EDT
I was wrong on where the errror was coming in. I am using IP aliasing on this
system (configured by hand through rc.local, following the formula in the HOWTO
and a Sys Admin article), and it turns out that ifconfig was (1) assigning the
wrong netmask to the aliased IP's and (2) adding the 64.0.0.0 line as some sort
of byproduct of that mistake, having apparently deduced that I had a Class A.
Explicitly setting the netmask for the aliased IPs fixed it. On a similar system
with a 255.255.255.0 netmask ifconfig properly used the mask for the primary
port for the aliased IPs too, but on this one with 255.255.255.248 for the mask
it gave the aliased IPs a 255.0.0.0 netmask. 

I guess when ifconfig was written the authors could conceive of owning a whole
Class A, but not of subnetting below a Class C. Sorry for my confusion. Thanks
for the response.
Comment 3 Nalin Dahyabhai 2000-10-02 01:51:32 EDT
Okay.  I guess I'll close this bug report then....

Note You need to log in before you can comment on or make changes to this bug.