Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1787989

Summary: NM OVS: Activating of OVS internal port fail with NM_DEVICE_STATE_UNMANAGED
Product: Red Hat Enterprise Linux 8 Reporter: Gris Ge <fge>
Component: NetworkManagerAssignee: sushil kulkarni <sukulkar>
Status: CLOSED ERRATA QA Contact: Desktop QE <desktop-qa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.2CC: acardace, atragler, bgalvani, lrintel, pasik, rkhan, sukulkar, thaller, till, vbenes
Target Milestone: rcFlags: pm-rhel: mirror+
Target Release: 8.2   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: NetworkManager-1.22.8-1.el8 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-04-28 16:54:11 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1724901, 1738136    
Attachments:
Description Flags
System logs with NM trace enabled
none
System logs with NM trace enabled (NetworkManager-1.23.1-24994.49472438cd.el8)
none
System logs with NM trace enabled (NetworkManager-1.23.1-25012.38977d8dcc.el8.x86_64) none

Description Gris Ge 2020-01-06 03:54:31 UTC
Created attachment 1650018 [details]
System logs with NM trace enabled

Description of problem:

When activating a OVS internal internal after its port been activated,

I got state-change callback on NM.ActivateConnection with:

      reason: NM_ACTIVE_CONNECTION_STATE_REASON_DEVICE_DISCONNECTED
      device state: NM_DEVICE_STATE_UNMANAGED



Version-Release number of selected component (if applicable):

The NM is built from master(f2dbf8fbc0efd3853100c6e7d7187d649e792793)
with fix from
https://gitlab.freedesktop.org/NetworkManager/NetworkManager/merge_requests/358


How reproducible:
10%

Steps to Reproduce:
1. Use nmstate to create OVS bridge with 1 internal interface and 1 system interface.
2.
3.

Actual results:

Activation failed.


Expected results:

No failure

Additional info:

Comment 1 Gris Ge 2020-02-11 06:24:29 UTC
Hi Beniamino,

This problem still exists in NetworkManager-1.22.7-24666.dbd7083881.el8.x86_64

Any update on this?

Comment 2 Gris Ge 2020-02-11 06:26:56 UTC
You may use the same reproducer in bug #1781165

Comment 3 Beniamino Galvani 2020-02-13 16:10:48 UTC
https://gitlab.freedesktop.org/NetworkManager/NetworkManager/merge_requests/412

Gris, could you test the patch in the merge request? I tried the reproducer and did 500 iterations without errors.

Comment 4 Gris Ge 2020-02-14 13:09:10 UTC
Hi Beniamino,

I still hit NM_ACTIVE_CONNECTION_STATE_REASON_DEVICE_DISCONNECTED error on RHEL 8.2:

NetworkManager-1.23.1-24994.49472438cd.el8.x86_64
openvswitch2.12-2.12.0-12.el8fdp.x86_64
kernel-4.18.0-167.el8.x86_64

Comment 5 Gris Ge 2020-02-14 13:10:28 UTC
Created attachment 1663114 [details]
System logs with NM trace enabled (NetworkManager-1.23.1-24994.49472438cd.el8)

Comment 6 Beniamino Galvani 2020-02-17 09:48:48 UTC
Thanks Gris, I found another issue. Can you please test the additional patch in the MR?

Comment 7 Gris Ge 2020-02-17 14:41:45 UTC
Created attachment 1663535 [details]
System logs with NM trace enabled (NetworkManager-1.23.1-25012.38977d8dcc.el8.x86_64)

Still have the NM_ACTIVE_CONNECTION_STATE_REASON_DEVICE_DISCONNECTED problem.

Comment 11 Vladimir Benes 2020-02-21 12:13:03 UTC
covered by the nmstate test executing nmstate's CI.

Comment 13 errata-xmlrpc 2020-04-28 16:54:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1847