Bug 178801 - azureus should use icons from current theme
Summary: azureus should use icons from current theme
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: azureus (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Anthony Green
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-24 14:53 UTC by Anthony Green
Modified: 2008-01-28 18:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-28 18:48:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Anthony Green 2006-01-24 14:53:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
We should use the java-gnome libraries from FC to find and use the proper icons instead of the stock icons from azureus (for stop/up/down/go/etc).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start azureus
2.Look at the clashing icons
3.
  

Additional info:

Comment 1 Anthony Green 2006-01-24 15:51:58 UTC
Finding properly themed icon files to feed to SWT should be easy.  Here's an 
example before I forget.

import org.gnu.gtk.*;

public class i
{
  public static void main (String args[])
  {
    Gtk.init(args);
    IconTheme it = IconTheme.getDefault ();
    System.out.println (it.lookupIcon("stop", 32,
IconLookupFlags.NO_SVG).getFilename());
  }
}


Comment 2 Anthony Green 2006-01-26 07:33:06 UTC
Version 2.3.0.6-19 includes a patch to partially theme the toolbar icons using
java-gnome.  However, there are still a few little icons to theme, so I'll leave
this open for now.


Comment 3 Lillian Angel 2008-01-28 18:48:43 UTC
I am closing this. The gtk icons were removed because they are incompatible with
the new version of azureus and java


Note You need to log in before you can comment on or make changes to this bug.