Bug 1788042 - [virtio-win][balloon][whql]windows guest BSOD when run several WHQL jobs in HCK.
Summary: [virtio-win][balloon][whql]windows guest BSOD when run several WHQL jobs in HCK.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: virtio-win
Version: 8.2
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: 8.0
Assignee: ybendito
QA Contact: xiagao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-06 08:43 UTC by xiagao
Modified: 2020-05-01 03:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:05:16 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
BSOD(7E) (13.44 KB, image/png)
2020-01-06 08:43 UTC, xiagao
no flags Details
BSOD(50) (12.77 KB, image/png)
2020-01-06 08:48 UTC, xiagao
no flags Details
driver install failed screenshot (278.32 KB, image/png)
2020-01-09 07:02 UTC, xiagao
no flags Details
setupapi log(success and fail) (14.44 KB, application/gzip)
2020-01-16 05:53 UTC, xiagao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2020:1757 None None None 2020-04-28 16:05:30 UTC

Description xiagao 2020-01-06 08:43:19 UTC
Created attachment 1650062 [details]
BSOD(7E)

Description of problem:
windows guest BSOD when run several WHQL jobs.

DF - Concurrent Hardware And Operating System (CHAOS) Test (Certification) -win7,win2008r2,win8,win8.1,win2012,win2012r2
DF - PNP Surprise Remove Device Test (Certification) -win7,win2008r2,win8,win8.1,win2012,win2012r2

DF - PNP Rebalance Fail Restart Device Test (Certification) -win7 ,win8,win8.1,win2012r2

DF - PNP Stop (Rebalance) Device Test (Certification) -win7,win8	 
DF - PNP Rebalance Request New Resources Device Test (Certification) -win7,win8	


Version-Release number of selected component (if applicable):
kernel-4.18.0-161.el8.x86_64
qemu-kvm-4.2.0-4.module+el8.2.0+5220+e82621dc.x86_64
seabios-1.12.0-5.module+el8.2.0+4793+b09dd2fb.x86_64
virtio-win-prewhql-175

How reproducible:
100%

Steps to Reproduce:
1.boot up windows guest
/usr/libexec/qemu-kvm -name 175BLN083235H9Z -enable-kvm -m 3G -smp 4 -uuid 1d363e58-2493-4f3f-89b5-8294760e2c00 -nodefaults -cpu EPYC,hv_stimer,hv_synic,hv_time,hv_relaxed,hv_vpindex,hv_spinlocks=0xfff,hv_vapic,hv_reset,hv-tlbflush -chardev socket,id=charmonitor,path=/tmp/175BLN083235H9Z,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb -drive file=175BLN083235H9Z,if=none,id=drive-ide0-0-0,format=raw,cache=none -device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0,bus=ide.0,unit=0 -drive file=/home/kvm_autotest_root/iso/ISO/Win8/en_windows_8_enterprise_x86_dvd_917587.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,drive=drive-ide0-1-0,id=ide0-1-0,bus=ide.1,unit=0 -drive file=175BLN083235H9Z.iso,if=none,media=cdrom,id=drive-ide0-1-1,readonly=on,format=raw -device ide-cd,drive=drive-ide0-1-1,id=ide0-1-1 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device e1000,netdev=hostnet0,id=net0,mac=00:52:3e:10:0d:bd -device usb-tablet,id=input0 -vnc 0.0.0.0:0 -vga std -M q35 -device pcie-root-port,bus=pcie.0,id=root1.0,slot=1 -device virtio-balloon-pci,id=balloon0,bus=root1.0

2.submit jobs in HCK.
DF - Concurrent Hardware And Operating System (CHAOS) Test (Certification)
DF - PNP Stop (Rebalance) Device Test (Certification)	
DF - PNP Rebalance Request New Resources Device Test (Certification)	
DF - PNP Rebalance Fail Restart Device Test (Certification)
DF - PNP Surprise Remove Device Test (Certification)

3.

Actual results:
BSOD(7e/50)

Expected results:
Jobs all pass.

Additional info:
1. didn't hit bsod with virtio-win-prewhql-169(last released version),so it's a regression.

Comment 1 xiagao 2020-01-06 08:47:16 UTC
The memory.dump file is located at
http://fileshare.englab.nay.redhat.com/pub/section2/coredump/virtio-win/balloon-whql-dump/

Comment 2 xiagao 2020-01-06 08:48:06 UTC
Created attachment 1650066 [details]
BSOD(50)

Comment 4 xiagao 2020-01-08 02:09:21 UTC
(In reply to ybendito from comment #3)
> 1. Is Win10/2016/2019 WHCK ok or not tested yet?
Tested and all pass for win10+.

> 2. Did you try to run HCK on some OS when it fails now with 169 in the same
> environment of today?
Yes, in the same env and just downgrade driver to 169 version,didn't hit BSOD.

Comment 6 xiagao 2020-01-09 07:00:57 UTC
Fail to install 176 balloon driver on win8.1-32/64.
Success on win8-32/64 and win201264.
Have not test on win2012r2.

Comment 7 xiagao 2020-01-09 07:02:05 UTC
Created attachment 1650914 [details]
driver install failed screenshot

Comment 11 xiagao 2020-01-10 08:22:34 UTC
Run those cases with 176 balloon driver on win8,win8.1,win2012 and win2012r2, all PASS.

Comment 12 xiagao 2020-01-14 02:51:15 UTC
Yuri, hi

Could you help check comment 10?

Thanks,
xiagao

Comment 15 xiagao 2020-01-16 05:53:31 UTC
Created attachment 1652622 [details]
setupapi log(success and fail)

Comment 16 ybendito 2020-01-19 09:48:33 UTC
Released in build 176

Comment 25 errata-xmlrpc 2020-04-28 16:05:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2020:1757

Comment 26 ybendito 2020-05-01 03:15:43 UTC
In my opinion, no special documentation required as the build with the bug was never released.
The problem exists only in intermediate build


Note You need to log in before you can comment on or make changes to this bug.