Bug 178807 - Netdump server does not receive packets when bound to an alias address
Netdump server does not receive packets when bound to an alias address
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: netdump (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Graf
:
: 185197 (view as bug list)
Depends On: 171405
Blocks: 181409
  Show dependency treegraph
 
Reported: 2006-01-24 10:22 EST by Thomas Graf
Modified: 2014-06-18 04:28 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2006-0492
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 17:27:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Graf 2006-01-24 10:22:10 EST
+++ This bug was initially created as a clone of Bug #171405 +++

Description of problem:

The netdump-server is running on a machine with an eth card that has a few IP
addresses, all but one of which are assigned via interface aliases.  All these
IP addresses are on the same logical subnet (vlan). The netdump clients all
point to an IP that is on one of the IPs that is associated with and interface
alias.  I found through network sniffing on the server side that the netdump
client sends its request to IP A, and while the server *does* receive the
request and answer back, it answers from the main non-aliased IP B.

Talking to A and hearing back from B apparently doesn't fly with the netdumping
client.  When I change the client to point at IP B... it works just fine.

From my understanding of it, the netdump-server would in fact answer back to the
client from an aliased IP A if it was bound specifically to that IP.  Is there
a way to get the netdump-server to bind to a specific IP address?  This is an
option for most other network services... but I don't see any mention of that in
the netdump-server man page or init script.



Version-Release number of selected component (if applicable):
netdump-0.7.7-2
netdump-server-0.7.7-2

How reproducible:
100%

Steps to Reproduce:
1. Configure a netdump server with multiple addresses via ethernet aliases.  All
addresses should be on the same subnet.
2. Configure the netdump client to dump to one of the aliased addresses on the
server.
3. Initiate a netdump.  The return packets will come from a different IP
address, and so the netdump client will discard them.
  
Actual results:
The netdump server will timeout when trying to handshake with the client.

Expected results:
A full netdump should be taken.

Additional info:
This was originally discussed in bz #145476.  This bugzilla was created due to
confusion in that bugzilla.  Too many issues were being debugged.

-- Additional comment from tgraf@redhat.com on 2006-01-24 10:18 EST --
Fix commited in version 0.7.16-1
Comment 5 Bob Johnson 2006-04-11 12:51:07 EDT
This issue is on Red Hat Engineering's list of planned work items 
for the upcoming Red Hat Enterprise Linux 4.4 release.  Engineering 
resources have been assigned and barring unforeseen circumstances, Red 
Hat intends to include this item in the 4.4 release.
Comment 6 Thomas Graf 2006-04-25 19:39:05 EDT
*** Bug 185197 has been marked as a duplicate of this bug. ***
Comment 13 Red Hat Bugzilla 2006-08-10 17:27:16 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0492.html

Note You need to log in before you can comment on or make changes to this bug.