Bug 1788139 - Operator metrics cannot be scraped in IPv6 cluster
Summary: Operator metrics cannot be scraped in IPv6 cluster
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-apiserver
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Michal Fojtik
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks: 1790442
TreeView+ depends on / blocked
 
Reported: 2020-01-06 14:24 UTC by Pawel Krupa
Modified: 2020-05-04 11:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1790442 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:22:33 UTC
Target Upstream Version:


Attachments (Terms of Use)
must gather (18.92 MB, application/gzip)
2020-01-06 14:24 UTC, Pawel Krupa
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:23:09 UTC

Internal Links: 1788140 1788142 1788143

Description Pawel Krupa 2020-01-06 14:24:40 UTC
Created attachment 1650122 [details]
must gather

Description of problem:
In IPv6 cluster metrics from apiserver-operator cannot be scraped due to connection refused error

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-12-18-145749-ipv6.1

How reproducible:
Always

Steps to Reproduce:
1. Start a cluster
2. Go to prometheus UI -> targets (this needs to be done with port-forward, due to https://bugzilla.redhat.com/show_bug.cgi?id=1788135, cmd: "-n openshift-monitoring port-forward svc/prometheus-operated 9090")

Actual results:
`openshift-apiserver-operator/openshift-apiserver-operator/0` is DOWN


Expected results:
`openshift-apiserver-operator/openshift-apiserver-operator/0` is UP


Additional info:

Comment 3 Xingxing Xia 2020-03-24 09:08:28 UTC
Verified in ipv6 4.4.0-0.nightly-2020-03-23-010639 env, is up now:
openshift-apiserver-operator/openshift-apiserver-operator/0 (1/1 up)
https://[fd01::1:68f4:caff:fe00:50]:8443/metrics  up  endpoint="https" instance="[fd01::1:68f4:caff:fe00:50]:8443" job="metrics" namespace="openshift-apiserver-operator" pod="openshift-apiserver-operator-6997786c68-v82ld" service="metrics"

Comment 5 errata-xmlrpc 2020-05-04 11:22:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.