Bug 178830 - Unable to configure a NFS share with different settings for different systems
Unable to configure a NFS share with different settings for different systems
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-nfs (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
: 178831 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-24 12:46 EST by Mike Jang
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-30 11:52:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Jang 2006-01-24 12:46:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
Can't configure different settings for a share; when I try with NFS, one setting overwrites the other in /etc/exports. 

For example, if I want to configure (ro,sync) for *.example.com and (rw,sync) for Fedora.example.com, I'd go through the Add Share process twice.

The objective is to create the following in /etc/exports:

/mnt/share   *.example.com(ro,sync) Fedora.example.com(rw,sync)

This used to work with older versions of system-config-nfs, well at least on separate lines in /etc/exports, i.e.:

/mnt/share   *.example.com(ro,sync)
/mnt/share   Fedora.example.com(rw,sync)

Version-Release number of selected component (if applicable):
system-config-nfs-1.3.15-1

How reproducible:
Always

Steps to Reproduce:
1.Create a share with one set of NFS settings for one group of computers
2.Create the same share with different settings for a different group of computers
3.
  

Actual Results:  The second share overwrote the first in /etc/exports

Expected Results:  Two different settings for shares

Additional info:
Comment 1 Mike Jang 2006-01-24 12:47:26 EST
*** Bug 178831 has been marked as a duplicate of this bug. ***
Comment 2 Nils Philippsen 2006-01-30 11:52:39 EST
fixed in system-config-nfs-1.3.16-1
Comment 3 Fedora Update System 2006-01-30 12:30:54 EST
From User-Agent: XML-RPC

system-config-nfs-1.3.16-0.fc4.2 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.