Bug 178847 - Instructions for new users on burning ISO files
Instructions for new users on burning ISO files
Status: CLOSED CURRENTRELEASE
Product: Fedora Infrastructure
Classification: Retired
Component: website (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Greg DeKoenigsberg
Elliot Lee
: FutureFeature
Depends On:
Blocks: fc5-relnotes-traqr
  Show dependency treegraph
 
Reported: 2006-01-24 15:01 EST by David Fletcher
Modified: 2013-01-09 22:40 EST (History)
6 users (show)

See Also:
Fixed In Version: 20060523
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-23 09:52:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A Read-Me file, in the DOS type format with CR + LF line endings for use by MS Windows users (4.44 KB, text/plain)
2006-01-24 15:01 EST, David Fletcher
no flags Details
README_BURNING_ISOS.txt (5.92 KB, text/plain)
2006-02-24 13:47 EST, Patrick Barnes
no flags Details
README_BURNING_ISOS.txt (5.92 KB, text/plain)
2006-02-24 13:51 EST, Patrick Barnes
no flags Details
README_BURNING_ISOS.txt (5.92 KB, text/plain)
2006-03-29 17:15 EST, Patrick Barnes
no flags Details
README_BURNING_ISOS.txt (5.97 KB, text/plain)
2006-04-01 02:02 EST, Patrick Barnes
no flags Details

  None (edit)
Description David Fletcher 2006-01-24 15:01:05 EST
Description of problem: No detailed information for new users of FC about
downloading, checking and burning the ISO files


Version-Release number of selected component (if applicable): N/A


How reproducible: N/A


Steps to Reproduce: N/A
1.
2.
3.
  
Actual results: N/A


Expected results: N/A


Additional info: Text file attached for addition to the Fedora ISO download pages
Comment 1 David Fletcher 2006-01-24 15:01:05 EST
Created attachment 123633 [details]
A Read-Me file, in the DOS type format with CR + LF line endings for use by MS Windows users
Comment 2 Karsten Wade 2006-02-01 19:07:25 EST
Jeremy gave a thumbs up to this idea.  Sounds as if we can get this into the 
directory with the downloadable ISOs.

Suggestions for filename: 
  HOW_TO_CHECK_AND_BURN_ISO_FILES
  HOW_TO_CHECK_AND_BURN_ISO_FILES_TO_CD
  HOW_TO_CHECK_AND_BURN_ISOs
  HOW_TO_CHECK_AND_BURN_ISO_FILES_ON_MICROSOFT_WINDOWS  <== quaid vote
  README_BURNING_ISOs

I'm going to look for some volunteers to check my edits and make sure we are
treating our Windows users properly.

Please see the attachment I am adding next and:

* Check that the CR + LF still works
* Confirm that I  didn't mess up anything technical

Click on the [edit] link for the attachment and then generate a diff(erence)
against the original.

David -- we don't have a solid process for contributions of content from the
community.  You need to license your copyrighted work for distribution.  You may
choose any license you wish, but the one we want for Fedora Docs is the OPL
without options:

http://www.opencontent.org/openpub/

It is OK to use more than one license, as long as one of them is the OPL.  That
is the license we are (going to be) releasing content under.  Currently we are
using the GNU FDL, but I expect that to be phased out Real Soon Now.

If you agree to this, we'll need to add this to the end of the file (properly CR
+ LF formatted):

## begin license block
Copyright (c) 2006 by David Fletcher. This material may be distributed only
subject to the terms and conditions set forth in the Open Publication License,
v1.0 or later (the latest version is presently available at
http://www.opencontent.org/openpub/).
## end license block

Please submit a new attachment with the license included.  Thanks!
Comment 3 David Fletcher 2006-02-02 18:04:26 EST
Comment on attachment 123633 [details]
A Read-Me file, in the DOS type format with CR + LF line endings for use by MS Windows users

INTRODUCTION

This Operating System is distributed in the form of ISO 9660 standard files.
ISO 9660 is the file system used for storing data on CD-ROM disks.

Before the Operating System can be installed on a computer, the ISO files must
be transfered (burned) to blank compact disk media (CD-R or CD-RW). This how-to
document describes the necessary process.

It is assumed that the reader of this document has no experience of Linux, and
is using using Microsoft Windows for the purpose of downloading and burning
his/her first set of installation files.


DOWNLOADING

The ISO files are large, and downloading is likely to take a long time,
especially when using a dial up modem. The use of download software such as
GetRight is recommended. Download software is available inexpensively as
shareware from sites such as http://www.tucows.com/ and enables lengthy
downloads to be resumed after interruptions.

Five files are needed from the download server:-

  FCx-i386-disc1.iso
  FCx-i386-disc2.iso
  FCx-i386-disc3.iso
  FCx-i386-disc4.iso
  SHA1SUM

where FCx will be FC4, FC5 etc. as new releases are made available.

Make a new, empty directory on drive C and download all of the files into it.


CHECKING

There is always the possibility of errors during the download, so it is VERY
IMPORTANT to check that the files have not been corrupted in any way. This is
the purpose of the SHA1SUM file. It contains one line for each of the available
ISO files, with a string of checking characters computed from the original ISO
files.

A software download, sha1sum.exe, is required to do the checking. See the
instructions and the link for downloading the program here:-

http://lists.gnupg.org/pipermail/gnupg-announce/2004q4/000184.html

sha1sum.exe computes and displays check strings. It is actually a command
prompt prompt program. To use it, save sha1sum.exe to the same directory as the
ISO files. Start a Windows command prompt, and cd into the download directory.
Run sha1sum with each ISO file like this:-

sha1sum.exe FCx-i386-disc1.iso
sha1sum.exe FCx-i386-disc2.iso
sha1sum.exe FCx-i386-disc3.iso
sha1sum.exe FCx-i386-disc4.iso

again where FCx is replaced by FC4 or FC5 etc.

Open the file SHA1SUM with a text editor such as Notepad to display its
contents. Make sure the check string displayed by sha1sum.exe for EACH of the
downloaded ISO files EXACTLY matches the corresponding check string in SHA1SUM.

So long as all of the check strings match, the ISO files can be burned to
media. If any do not match, the file(s) will have to be downloaded again.


BURNING

The process of burning a CD is made almost invisible to the users of Windows
software.

Windows applications let users burn data files such as mp3 and photographs by
simply dragging the files into a box and clicking the Burn button. What happens
in reality is, the CD burning software performs two operations. Firstly it
creates an ISO 9660 standard file, just like the ones downloaded from Fedora,
from the files that were dragged into the burn box. Secondly it transfers that
ISO file onto the blank CD.

To create the Fedora installation CDs, it is VITAL that ONLY the SECOND
operation is performed using the Fedora ISO files. The steps required to do
this using two popular CD burning applications are listed below.

Using:-
Roxio Easy Media Creator 7
Under "Applications"
click "Creator Classic"
then under "Other Tasks"
use "Burn from Disc Image File"

Using:-
Nero Burning ROM 5
Just use
   File
     Burn Image

and browse for the ISO files in each case. You should now burn each of the
Fedora ISO files to produce a working set of installation CDs. It might be
reassuring to burn just disk 1 first, then:-

  reboot the computer
  press the Del key during booting to get into the BIOS setup menu
  make sure the BIOS is set up to boot from the CD drive first, then the hard
disk drive
  make sure the Fedora disk 1 is in the CD drive
  exit the BIOS menu, saving your changes.

The computer should now boot from the CD drive, and start the Fedora
installation program. It should offer to test the integrity of the installation
media. If this works, all is well. Exit from the installer (it will change
absolutely nothing on your computer unless it is explicitly told to do so) and
reboot the computer. Remember to remove the Fedora disk 1 so that the computer
boots Windows.

Burn the other three ISO images.

End.


Copyright (c) 2006 by David Fletcher. This material may be distributed only
subject to the terms and conditions set forth in the Open Publication License,
v1.0 or later (the latest version is presently available at
http://www.opencontent.org/openpub/).
Comment 4 David Fletcher 2006-02-02 18:12:19 EST
I've added the license block to the end of the file, but I couldn't find how to
change the attachment itself, only edit it then submit the new version as a comment.

I suspect bugzilla might be converting the line endings back to the Unix type.
The way to set them back to DOS is to load the text into Kate and use Tools -
End of Line - Windows/DOS. Presence of both LF and CR at the line endings can be
easily checked by viewing the file with KHexEdit.
Comment 5 Karsten Wade 2006-02-20 13:43:24 EST
This file is most relevant for the final release, as opposed to the testing
where ISO burning is the least of their concerns. :)

Jeremy, Jesse -- can we get this file in the directory with the ISOs for FC5
release?

Yeah, I still haven't picked a preferred name. :)

Setting to block the FC5 relnotes tracker, so we docs doesn't lose track of it.
Comment 6 Jeremy Katz 2006-02-20 15:03:19 EST
Pick a name and we'll suck it into the fedora-release package from which we
should be able to suck it into the tree.

And I still owe you a description of the release notes -> fedora-release
process.  Hopefully this afternoon.
Comment 7 Robert 'Bob' Jensen 2006-02-24 03:14:13 EST
Do we want to link to this file from the release notes? Does it have a wiki page
set up yet?
Comment 8 Karsten Wade 2006-02-24 12:16:45 EST
The file name shall be:

README_BURNING_ISOS.txt  <== file extension a must for Windows

We can add more information on burning under *NIX, OSX, etc. later.

This does not have a Wiki page, let's set one up and find a good place to
reference it from the release notes.

People may not read this, but at least #fedora can learn to send folks to the
README. :)

Comment 9 Patrick Barnes 2006-02-24 12:31:59 EST
This is a good start.  
  
David, would you mind signing up in our Account System and signing our CLA?   
This would allow us to add you to our wiki's EditGroup.  
  
http://fedoraproject.org/wiki/Infrastructure/AccountSystem  
  
I'd like to put this material on the wiki to facilitate quick editing and to  
allow others to contribute new material easily.  In particular, this document  
will need modifications to cover other Fedora Core versions and to include  
directions for other platforms and tools.  
 
Comment 10 Patrick Barnes 2006-02-24 13:47:05 EST
Created attachment 125196 [details]
README_BURNING_ISOS.txt

I'm attaching the results of my first review of this document.	In particular,
we need to avoid making assumptions about the user's system and software
preferences where possible.  I've updated it to be more accurate for Fedora
Core 5, I've used some conventions that ready the document for the wiki, and
I've made a few changes for technical accuracy.
Comment 11 Patrick Barnes 2006-02-24 13:51:24 EST
Created attachment 125198 [details]
README_BURNING_ISOS.txt

Updating with fixed line endings.  My text editor misbehaved a little.
Comment 12 David Fletcher 2006-03-20 10:27:34 EST
The FC5 isos are now visible on the download server if the path is typed into
the browser. But this file is not in the directory.

Has it been forgotten?

Have I not done something I should have?

Is it one last job to be done before the release is officially announced?
Comment 13 Jesse Keating 2006-03-20 12:06:41 EST
We suck again.  Between all the respins, some internal system outages, and a
broken kernel on the tree generator we seemed to have forgotten to include this.
 I guess we'll try for FC6 Test releases :/
Comment 14 David Fletcher 2006-03-20 12:20:12 EST
Hang on - all is not lost!

This bug was never intended to be part of the distribution itself. It's just an
aid to help newbies get their first set of installation CDs downloaded and burned.

So the text file just needs to be copied into the download directory with a
suitable name. It doesn't even need to be included in SHA1SUM.
Comment 15 Karsten Wade 2006-03-29 15:51:18 EST
Jesse:

Is it absolutely impossible to get this file in the same directory as the ISOs
and available to the mirrors?

Even if it is five more minutes work for each mirror, it is a multiplied savings
across the users and help fora/lists.

David:

Did you review the changes made by Patrick in attachment #125198 [details] :

https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=125198


Comment 16 Jesse Keating 2006-03-29 15:58:45 EST
I can make the file show up.  I need you guys to finish editing it.
Comment 17 David Fletcher 2006-03-29 16:12:42 EST
I thought it was finished.

See comment 14 from 9 days ago!

Just need to make sure it has windoze style line endings and use scp or whatever
to put it in the download folder.

BTW this is from an email of 2006-03-05:-

> David, would you mind signing up in our Account System and signing our CLA?
> This would allow us to add you to our wiki's EditGroup.
>
> http://fedoraproject.org/wiki/Infrastructure/AccountSystem
>
> I'd like to put this material on the wiki to facilitate quick editing and
> to allow others to contribute new material easily.  In particular, this
> document will need modifications to cover other Fedora Core versions and to
> include directions for other platforms and tools.

Karsten,

I've done this, I have the "CLA request completed successfully" message, and 
downloaded the client side certificate.

What do I do now? It doesn't seem very obvious.

Dave Fletcher

-- 
Registered Linux user number 393408
Comment 18 David Fletcher 2006-03-29 16:29:31 EST
I thought it was finished.

See comment 14 from 9 days ago!

Just need to make sure it has windoze style line endings and use scp or whatever
to put it in the download folder.

BTW this is from an email of 2006-03-05:-

> David, would you mind signing up in our Account System and signing our CLA?
> This would allow us to add you to our wiki's EditGroup.
>
> http://fedoraproject.org/wiki/Infrastructure/AccountSystem
>
> I'd like to put this material on the wiki to facilitate quick editing and
> to allow others to contribute new material easily.  In particular, this
> document will need modifications to cover other Fedora Core versions and to
> include directions for other platforms and tools.

Karsten,

I've done this, I have the "CLA request completed successfully" message, and 
downloaded the client side certificate.

What do I do now? It doesn't seem very obvious.

Dave Fletcher

-- 
Registered Linux user number 393408
Comment 19 Jesse Keating 2006-03-29 16:34:32 EST
'Just need to make sure it has windoze style line endings' and 'David:

Did you review the changes made by Patrick in attachment #125198 [details] [edit] :'
doesn't sound like done to me.
Comment 20 Karsten Wade 2006-03-29 16:56:28 EST
I think I get that Dave reviewed the changes made by Patrick, and Patrick
confirmed originally that his changes were good and clean.

I say SHIP ACK.

But since I don't have a Windows machine to view it on ... we have to trust
Patrick's changes.

If there are no 'nay's, then let's push it out, thanks.
Comment 21 Patrick Barnes 2006-03-29 17:15:25 EST
Created attachment 127026 [details]
README_BURNING_ISOS.txt
Comment 22 Patrick Barnes 2006-03-29 17:18:53 EST
I've updated the file to reflect changes to the ISO names with FC5. 
 
Dave: 
 
Create an account in the fedoraproject.org wiki and we'll grant you edit 
access.  This account is separate from the Account System account, and should 
be formed from your real name, like this: DaveFletcher 
 
http://fedoraproject.org/wiki/WikiEditing 
Comment 23 Patrick Barnes 2006-04-01 02:02:14 EST
Created attachment 127169 [details]
README_BURNING_ISOS.txt

At David's request, I've hard-wrapped the document.  I've used a width of 78
columns.  I think we should maintain the document without wrapping, but it
probably is a good idea to wrap for publishing.
Comment 24 Patrick Barnes 2006-04-01 02:26:37 EST
Now that David has completed the CLA and is in the EditGroup, I've wikified 
this document.  We can further develop it on the wiki and use our regular 
maintenance and publication processes. 
 
http://fedoraproject.org/wiki/Docs/Drafts/BurningDiscs 
 
Comment 25 Patrick Barnes 2006-05-23 09:52:44 EDT
Since this is in the wiki and on the download servers, this bug has served its 
purpose.  We can begin using our normal processes for this document now.

I'm closing this as CURRENTRELEASE.

Thank you all for your efforts.

Note You need to log in before you can comment on or make changes to this bug.