Bug 178853 - Static libraries have been disabled in the devel package in the latest release.
Static libraries have been disabled in the devel package in the latest release.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libsigc++20 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-24 16:14 EST by Alistair Riddoch
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 02:02:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alistair Riddoch 2006-01-24 16:14:16 EST
Description of problem:

Static libraries have been disabled in the devel package in the latest release.

Version-Release number of selected component (if applicable):

2.0.16-2

How reproducible:

Always

Additional info:

Static versions of libraries are essential for creating profiled builds, as the
GNU profiler does not profile code that is linked dynamically. Please can static
libraries be re-enabled.
Comment 1 Denis Leroy 2006-01-25 13:26:30 EST
It's a Fedora Extras policy to no longer package the static libraries in devel
packages, but the profile build argument is an interesting one. Let me revisit
this in the next release...
Comment 2 Warren Togami 2006-02-17 16:34:57 EST
IMHO, profiling is not a good argument because this refers to development of the
software and not actual usage.  Nothing stops the software developer from
building their own static copy of a given library to take part of their own
profiling.  Maybe the benefits of excluding static libraries outweigh the rare
benefit of being able to do this?
Comment 3 Denis Leroy 2006-02-20 17:53:07 EST
Right, but aren't devel libraries precisely targeted at developers ??
Comment 4 Denis Leroy 2006-03-01 02:02:15 EST
Alistair,

Well this is a bit of a hot/controversial issue, so I've let static libraries
disabled by default. However, i added a optional macro to enable them easily, so
i would recommend that you recompile your own version of libsigc++ with the
command :

rpmbuild --rebuild --with static <srpm>

Note You need to log in before you can comment on or make changes to this bug.