Bug 178865 - Compiled kernel panics
Compiled kernel panics
Status: CLOSED DUPLICATE of bug 126342
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-24 17:45 EST by John Klingler
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-24 18:33:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Klingler 2006-01-24 17:45:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040805 Netscape/7.2

Description of problem:
I installed FC4 on my dual Xeon computer. It runs fine. I compiled the FC4 kernel source using the config-2.6.11-1.1369_FC4smp. The the compiled FC4 kernel won't boot. It panics. I suspect the problem is one or more of the following:

1) The config-2.6.11-1.1369_FC4smp file is not the one used to build the kernel.

2) The FC4 compiler, gcc 4.0.0, is not the compiler used to build the kernel.

3) The wrong headers are being used to build the kernel.

In any case, the kernel panics with the following messages:
insmod: error inserting /lib/jbd.ko: -1 Invalid module format
ERROR: /bin/insmod exited abnormally with value 1 ! (pid 436)
insmod: error inserting /lib/ext3.ko: -1 Invalid module format
ERROR: /bin/insmod exited abnormally with value 1 ! (pid 437)
Unable to find device-mapper major-minor
  Reading all physical volumes. This may take a while...
  Found volume grou[ "VolGroup00" using metadatatype lvm2
  /proc/misc: No entry for device-mapper found
  Is device mapper missing from kernel?
  Failure to communicate with kernel device-mapper driver.
  0 logical volume(s) in volume group "VolGroup00" now active
mount: error 19 mounting ext3
ERROR opening /dev/console!!!!: 2
error dup2'ing fd of 0 to 0
error dup2'ing fd of 0 to 1
error dup2'ing fd of 0 to 2
switchroot: mount failed: 22
Kernel panic - not syncing: Attempted to kill init!

The problems all start with insmod griping about the module formats. Once the ext3 module fails, everything is hosed. The were no errors during the build. There were warnings during "make" but not about ext3. There were no warnings during "make modules_install."




Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1369_FC4smp

How reproducible:
Always

Steps to Reproduce:
1.cp FC4 kernel SRPM to /usr/src/redhat/SRPMS.
2.rpmbuild -bi --target i686-redhat-linux (SPEC only supports i486, i586, i686.
  Nothing gets installed so you have to go to steps 3 and 4.
3.cd ../BUILD/kernel-2.6.11/linux-2.6.11 and "make", "make install", "make
  modules_install"
4.reboot


Actual Results:  insmod: error inserting /lib/jbd.ko: -1 Invalid module format
ERROR: /bin/insmod exited abnormally with value 1 ! (pid 436)
insmod: error inserting /lib/ext3.ko: -1 Invalid module format
ERROR: /bin/insmod exited abnormally with value 1 ! (pid 437)
Unable to find device-mapper major-minor
  Reading all physical volumes. This may take a while...
  Found volume grou[ "VolGroup00" using metadatatype lvm2
  /proc/misc: No entry for device-mapper found
  Is device mapper missing from kernel?
  Failure to communicate with kernel device-mapper driver.
  0 logical volume(s) in volume group "VolGroup00" now active
mount: error 19 mounting ext3
ERROR opening /dev/console!!!!: 2
error dup2'ing fd of 0 to 0
error dup2'ing fd of 0 to 1
error dup2'ing fd of 0 to 2
switchroot: mount failed: 22
Kernel panic - not syncing: Attempted to kill init!


Expected Results:  login prompt

Additional info:
Comment 1 John Klingler 2006-01-24 18:05:24 EST
I forgot to add that for the first build I used the .config the came with the
SRPM, which panicked. For the second build I first executed a "make mrproper"
and "make xconfig". That also panicked. For my third build I executed a "make
mrproper" and copied /boot/config-2.6.11-1.1369_FC4smp, supposedly the config
for the running kernel, to /usr/src/redhat/BUILD/kernel-2.6.11/linux-2.6.11. I
thought that should work. It panicks just like the others. 
Comment 2 John Klingler 2006-01-24 18:18:43 EST
The problem is not the compiler. Here is the information on the jbd and ext3
modules for the running kernel and the panicking kernel. They were all compiled
with gcc 4.0.

ganymede:root: modinfo jbd
filename:       /lib/modules/2.6.11-1.1369_FC4smp/kernel/fs/jbd/jbd.ko
license:        GPL
vermagic:       2.6.11-1.1369_FC4smp SMP 686 REGPARM 4KSTACKS gcc-4.0
depends:
srcversion:     9BF9D55C8C58653881E7651

ganymede:root: modinfo ./jbd.ko
filename:       ./jbd.ko
license:        GPL
vermagic:       2.6.11-1.1369_FC4.rootxenU SMP 686 REGPARM 4KSTACKS gcc-4.0
depends:
srcversion:     9BF9D55C8C58653881E7651

ganymede:root: modinfo ext3
filename:       /lib/modules/2.6.11-1.1369_FC4smp/kernel/fs/ext3/ext3.ko
author:         Remy Card, Stephen Tweedie, Andrew Morton, Andreas Dilger,
Theodore Ts'o and others
description:    Second Extended Filesystem with journaling extensions
license:        GPL
vermagic:       2.6.11-1.1369_FC4smp SMP 686 REGPARM 4KSTACKS gcc-4.0
depends:        jbd
srcversion:     89DA5C1B28ED7CFDF420E49

ganymede:root: modinfo ./ext3.ko
filename:       ./ext3.ko
author:         Remy Card, Stephen Tweedie, Andrew Morton, Andreas Dilger,
Theodore Ts'o and others
description:    Second Extended Filesystem with journaling extensions
license:        GPL
vermagic:       2.6.11-1.1369_FC4.rootxenU SMP 686 REGPARM 4KSTACKS gcc-4.0
depends:        jbd
srcversion:     89DA5C1B28ED7CFDF420E49
Comment 3 Dave Jones 2006-01-24 18:33:18 EST

*** This bug has been marked as a duplicate of 126342 ***

Note You need to log in before you can comment on or make changes to this bug.