Bug 1788676 - Imagestreams cannot be imported on an IPv6 AWS cluster because registry.redhat.io is not IPv6 enabled
Summary: Imagestreams cannot be imported on an IPv6 AWS cluster because registry.redha...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Samples
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Gabe Montero
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On:
Blocks: 1771572 1798573
TreeView+ depends on / blocked
 
Reported: 2020-01-07 18:59 UTC by Marius Cornea
Modified: 2020-05-04 11:23 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Since registry.redhat.io did not support IPv6, samples operator should not attempt to install imagestreams since our samples are all hosted on registry.redhat.io Reason: IPv6 is a key initiative for OpenShift and Red Hat Result: samples operator will not break installs of OpenShift on IPv6
Clone Of:
: 1798573 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:23:07 UTC
Target Upstream Version:
xiuwang: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-samples-operator pull 214 None closed DEVEXP-507: bootstrap as removed for IPv6 2020-11-23 14:43:02 UTC
Github openshift cluster-samples-operator pull 221 None closed DEXP-507: Ipv6 disc boot removed 2 2020-11-23 14:42:38 UTC
Github openshift cluster-samples-operator pull 226 None closed Bug 1788676: keep tbr inaccessible clusteroperator reason set (bootstrap removed) 2020-11-23 14:42:38 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:23:40 UTC

Description Marius Cornea 2020-01-07 18:59:40 UTC
Description of problem:
Imagestreams cannot be imported on an IPv6 AWS cluster because registry.redhat.io is not IPv6 enabled:

oc -n openshift-cluster-samples-operator logs cluster-samples-operator-646866ccd9-d2l9t -c cluster-samples-operator:

[...]
time="2020-01-07T18:51:39Z" level=warning msg="Image import for imagestream ruby tag 2.3 generation 2 failed with detailed message Internal error occurred: registry.redhat.io/rhscl/ruby-23-rhel7:latest: Get https://registry.redhat.io/v2/: dial tcp 104.110.213.106:443: connect: network is unreachable"
time="2020-01-07T18:51:39Z" level=warning msg="Image import for imagestream ruby tag 2.4 generation 2 failed with detailed message Internal error occurred: registry.redhat.io/rhscl/ruby-24-rhel7:latest: Get https://registry.redhat.io/v2/: dial tcp 104.110.213.106:443: connect: network is unreachable"
time="2020-01-07T18:51:39Z" level=warning msg="Image import for imagestream ruby tag 2.5 generation 2 failed with detailed message Internal error occurred: registry.redhat.io/rhscl/ruby-25-rhel7:latest: Get https://registry.redhat.io/v2/: dial tcp 104.110.213.106:443: connect: network is unreachable"

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2020-01-06-101556-ipv6.1

How reproducible:
100%

Steps to Reproduce:
1. Deploy an IPv6 cluster on AWS
2. Check if sample imagestreams got imported successfully:
oc -n openshift-cluster-samples-operator logs cluster-samples-operator-646866ccd9-d2l9t -c cluster-samples-operator

Actual results:
Errors caused because registry.redhat.io is not reachable(it only resolves to an IPv4 address, not IPv6).

Expected results:
Default sample imagestreams get imported successfully.

Additional info:

Comment 10 errata-xmlrpc 2020-05-04 11:23:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.