Bug 1788682 - FreeCAD crash
Summary: FreeCAD crash
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freecad
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-07 19:31 UTC by Josh Cogliati
Modified: 2020-01-27 11:25 UTC (History)
5 users (show)

Fixed In Version: freecad-0.18.4-5.fc30 freecad-0.18.4-5.fc31
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-26 01:00:29 UTC
Type: Bug


Attachments (Terms of Use)

Description Josh Cogliati 2020-01-07 19:31:09 UTC
Description of problem:
FreeCad crashes multiple ways


Version-Release number of selected component (if applicable):
freecad-0.18.4-3.fc31.x86_64

How reproducible:


Steps to Reproduce:
1. Open FreeCAD
2. Open FemCalculixCantilever2D.FCStd
3.

Actual results:

Coin read error: Type 'BadType' is not derived from 'BadType'
	Occurred at line   1 in <memory>
Camera settings failed to read
Program received signal SIGSEGV, Segmentation fault.
#0  /lib64/libc.so.6(+0x3c6b0) [0x7f636209e6b0]
#1  0x7f6361c38ecf in SoState::getElement(int) from /lib64/libCoin.so.80+0x15f
#2  0x7f6361b49bec in SoCacheElement::set(SoState*, SoCache*) from /lib64/libCoin.so.80+0x1c
#3  0x7f6361c89de4 in SoSeparator::getBoundingBox(SoGetBoundingBoxAction*) from /lib64/libCoin.so.80+0x464
#4  0x7f6361c78878 in SoNode::getBoundingBoxS(SoAction*, SoNode*) from /lib64/libCoin.so.80+0x48
#5  0x7f6361a8e837 in SoAction::traverse(SoNode*) from /lib64/libCoin.so.80+0x67
#6  0x7f6361a8ecda in SoAction::apply(SoNode*) from /lib64/libCoin.so.80+0x28a
#7  0x7f6361d50c52 in SoRenderManagerP::setClippingPlanes() from /lib64/libCoin.so.80+0x92
#8  0x7f6361d7e0ed in SoDataSensor::trigger() from /lib64/libCoin.so.80+0xd
#9  0x7f6361d7fda6 in SoSensorManager::processDelayQueue(int) from /lib64/libCoin.so.80+0x3c6
#10  0x7f6363f9ac2c in SIM::Coin3D::Quarter::QuarterWidget::paintEvent(QPaintEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x1bc
#11  0x7f6363fa2951 in SIM::Coin3D::Quarter::SoQTQuarterAdaptor::paintEvent(QPaintEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x21
#12  0x7f6362b1134e in QWidget::event(QEvent*) from /lib64/libQt5Widgets.so.5+0x24e
#13  0x7f6362bbe942 in QFrame::event(QEvent*) from /lib64/libQt5Widgets.so.5+0x22
#14  0x7f6362e293d1 in QGraphicsView::viewportEvent(QEvent*) from /lib64/libQt5Widgets.so.5+0x161
#15  0x7f6363f9ad1e in SIM::Coin3D::Quarter::QuarterWidget::viewportEvent(QEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x9e
#16  0x7f63626a5c3e in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) from /lib64/libQt5Core.so.5+0x9e
#17  0x7f6362aceac5 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x75
#18  0x7f6362ad8150 in QApplication::notify(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x330
#19  0x7f6363d714e8 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x88
#20  0x7f63626a5df8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /lib64/libQt5Core.so.5+0x88
#21  0x7f6362b09ffa in QWidgetPrivate::sendPaintEvent(QRegion const&) from /lib64/libQt5Widgets.so.5+0x3a
#22  0x7f6362b0a839 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x7e9
#23  0x7f6362b0b553 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4d3
#24  0x7f6362b0a54c in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4fc
#25  0x7f6362b0b553 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4d3
#26  0x7f6362b0a54c in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4fc
#27  0x7f6362b0b553 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4d3
#28  0x7f6362b0a54c in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4fc
#29  0x7f6362b0b553 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4d3
#30  0x7f6362b0a54c in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4fc
#31  /lib64/libQt5Widgets.so.5(+0x181ebe) [0x7f6362ae0ebe]
#32  /lib64/libQt5Widgets.so.5(+0x1822c1) [0x7f6362ae12c1]
#33  0x7f6362af9415 in QWidgetPrivate::syncBackingStore() from /lib64/libQt5Widgets.so.5+0xa5
#34  0x7f6362b11708 in QWidget::event(QEvent*) from /lib64/libQt5Widgets.so.5+0x608
#35  0x7f6362c25ef8 in QMainWindow::event(QEvent*) from /lib64/libQt5Widgets.so.5+0x68
#36  0x7f6364031d9b in Gui::MainWindow::event(QEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x18b
#37  0x7f6362acead6 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x86
#38  0x7f6362ad8150 in QApplication::notify(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x330
#39  0x7f6363d714e8 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x88
#40  0x7f63626a5df8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /lib64/libQt5Core.so.5+0x88
#41  0x7f63626a8d9b in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) from /lib64/libQt5Core.so.5+0x14b
#42  /lib64/libQt5Widgets.so.5(+0x4957fb) [0x7f6362df47fb]
#43  /lib64/libQt5Widgets.so.5(+0x49e11b) [0x7f6362dfd11b]
#44  0x7f63626d0d4a in QObject::event(QEvent*) from /lib64/libQt5Core.so.5+0x22a
#45  0x7f6362e0af63 in QGraphicsScene::event(QEvent*) from /lib64/libQt5Widgets.so.5+0x93
#46  0x7f6362acead6 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x86
#47  0x7f6362ad8150 in QApplication::notify(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x330
#48  0x7f6363d714e8 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x88
#49  0x7f63626a5df8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /lib64/libQt5Core.so.5+0x88
#50  0x7f63626a8d9b in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) from /lib64/libQt5Core.so.5+0x14b
#51  /lib64/libQt5Core.so.5(+0x2b9ff7) [0x7f63626faff7]
#52  /lib64/libglib-2.0.so.0(g_main_context_dispatch+0x160) [0x7f6360088510]
#53  /lib64/libglib-2.0.so.0(+0x518a0) [0x7f63600888a0]
#54  /lib64/libglib-2.0.so.0(g_main_context_iteration+0x33) [0x7f6360088943]
#55  0x7f63626fae04 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /lib64/libQt5Core.so.5+0xe4
#56  0x7f6364042c65 in Gui::Sequencer::setValue(int) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x1c5
#57  0x7f6363499d30 in Base::SequencerBase::next(bool) from /usr/lib64/freecad/lib/libFreeCADBase.so+0x70
#58  0x7f636349a541 in Base::SequencerLauncher::next(bool) from /usr/lib64/freecad/lib/libFreeCADBase.so+0x61
#59  0x7f6363490c59 in Base::XMLReader::readFiles(zipios::ZipInputStream&) const from /usr/lib64/freecad/lib/libFreeCADBase.so+0x109
#60  0x7f63636c22db in App::Document::restore() from /usr/lib64/freecad/lib/libFreeCADApp.so+0x36b
#61  0x7f63637de704 in App::Application::openDocument(char const*) from /usr/lib64/freecad/lib/libFreeCADApp.so+0x194
#62  0x7f63637f9d3d in App::Application::sOpenDocument(_object*, _object*) from /usr/lib64/freecad/lib/libFreeCADApp.so+0xad
#63  /lib64/libpython3.7m.so.1.0(_PyMethodDef_RawFastCallKeywords+0x25e) [0x7f636310e61e]
#64  /lib64/libpython3.7m.so.1.0(_PyCFunction_FastCallKeywords+0x23) [0x7f636310e753]
#65  /lib64/libpython3.7m.so.1.0(+0x141923) [0x7f6363141923]
#66  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x55d2) [0x7f636317cc92]
#67  /lib64/libpython3.7m.so.1.0(_PyEval_EvalCodeWithName+0x2f0) [0x7f636312ecb0]
#68  /lib64/libpython3.7m.so.1.0(PyEval_EvalCodeEx+0x39) [0x7f636312fa09]
#69  /lib64/libpython3.7m.so.1.0(PyEval_EvalCode+0x1b) [0x7f63631be53b]
#70  /lib64/libpython3.7m.so.1.0(+0x1ff333) [0x7f63631ff333]
#71  /lib64/libpython3.7m.so.1.0(PyRun_StringFlags+0x7d) [0x7f63631ff3cd]
#72  0x7f636345fe2a in Base::InterpreterSingleton::runString[abi:cxx11](char const*) from /usr/lib64/freecad/lib/libFreeCADBase.so+0x6a
#73  0x7f63637f95f7 in App::Application::sLoadFile(_object*, _object*) from /usr/lib64/freecad/lib/libFreeCADApp.so+0x567
#74  /lib64/libpython3.7m.so.1.0(_PyMethodDef_RawFastCallKeywords+0x25e) [0x7f636310e61e]
#75  /lib64/libpython3.7m.so.1.0(_PyCFunction_FastCallKeywords+0x23) [0x7f636310e753]
#76  /lib64/libpython3.7m.so.1.0(+0x141923) [0x7f6363141923]
#77  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x55d2) [0x7f636317cc92]
#78  /lib64/libpython3.7m.so.1.0(_PyEval_EvalCodeWithName+0x2f0) [0x7f636312ecb0]
#79  /lib64/libpython3.7m.so.1.0(PyEval_EvalCodeEx+0x39) [0x7f636312fa09]
#80  /lib64/libpython3.7m.so.1.0(PyEval_EvalCode+0x1b) [0x7f63631be53b]
#81  /lib64/libpython3.7m.so.1.0(+0x1ff333) [0x7f63631ff333]
#82  /lib64/libpython3.7m.so.1.0(PyRun_StringFlags+0x7d) [0x7f63631ff3cd]
#83  /lib64/libpython3.7m.so.1.0(+0x1ff79b) [0x7f63631ff79b]
#84  /lib64/libpython3.7m.so.1.0(_PyMethodDef_RawFastCallKeywords+0x74) [0x7f636310e434]
#85  /lib64/libpython3.7m.so.1.0(_PyCFunction_FastCallKeywords+0x23) [0x7f636310e753]
#86  /lib64/libpython3.7m.so.1.0(+0x141923) [0x7f6363141923]
#87  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0xb59) [0x7f6363178219]
#88  /lib64/libpython3.7m.so.1.0(_PyEval_EvalCodeWithName+0x2f0) [0x7f636312ecb0]
#89  /lib64/libpython3.7m.so.1.0(PyEval_EvalCodeEx+0x39) [0x7f636312fa09]
#90  /lib64/libpython3.7m.so.1.0(PyEval_EvalCode+0x1b) [0x7f63631be53b]
#91  /lib64/libpython3.7m.so.1.0(+0x1ff333) [0x7f63631ff333]
#92  /lib64/libpython3.7m.so.1.0(PyRun_StringFlags+0x7d) [0x7f63631ff3cd]
#93  0x7f636345fe2a in Base::InterpreterSingleton::runString[abi:cxx11](char const*) from /usr/lib64/freecad/lib/libFreeCADBase.so+0x6a
#94  0x7f6363d9d784 in Gui::Command::doCommand(Gui::Command::DoCmd_Type, char const*, ...) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x134
#95  0x7f634c0adf70 in WebGui::BrowserView::onLinkClicked(QUrl const&) from /usr/lib64/freecad/lib/WebGui.so+0x820
#96  0x7f63626cfecb in QMetaObject::activate(QObject*, int, int, void**) from /lib64/libQt5Core.so.5+0x69b
#97  0x7f62f5e78cc9 in QWebView::linkClicked(QUrl const&) from /lib64/libQt5WebKitWidgets.so.5+0x39
#98  /lib64/libQt5WebKitWidgets.so.5(+0x37baa) [0x7f62f5e79baa]
#99  0x7f63626cfecb in QMetaObject::activate(QObject*, int, int, void**) from /lib64/libQt5Core.so.5+0x69b
#100  0x7f62f5e6e389 in QWebPage::linkClicked(QUrl const&) from /lib64/libQt5WebKitWidgets.so.5+0x39
#101  0x7f62f5e6eceb in QWebPage::acceptNavigationRequest(QWebFrame*, QNetworkRequest const&, QWebPage::NavigationType) from /lib64/libQt5WebKitWidgets.so.5+0x8b
#102  /lib64/libQt5WebKit.so.5(+0x5a9fd0) [0x7f62ed70efd0]
#103  /lib64/libQt5WebKit.so.5(+0x166446e) [0x7f62ee7c946e]
#104  /lib64/libQt5WebKit.so.5(+0x1648404) [0x7f62ee7ad404]
#105  /lib64/libQt5WebKit.so.5(+0x1648a39) [0x7f62ee7ada39]
#106  /lib64/libQt5WebKit.so.5(+0x16492f2) [0x7f62ee7ae2f2]
#107  0x7f62ee7aef31 in WebCore::FrameLoader::loadFrameRequest(WebCore::FrameLoadRequest const&, WebCore::Event*, WTF::PassRefPtr<WebCore::FormState>) from /lib64/libQt5WebKit.so.5+0x3e1
#108  /lib64/libQt5WebKit.so.5(+0x164a4ec) [0x7f62ee7af4ec]
#109  0x7f62ee7afa5a in WebCore::FrameLoader::urlSelected(WebCore::URL const&, WTF::String const&, WebCore::Event*, WebCore::LockHistory, WebCore::LockBackForwardList, WebCore::ShouldSendReferrer, WebCore::ShouldOpenExternalURLsPolicy) from /lib64/libQt5WebKit.so.5+0x3fa
#110  /lib64/libQt5WebKit.so.5(+0x11feeb5) [0x7f62ee363eb5]
#111  /lib64/libQt5WebKit.so.5(+0x1354c5a) [0x7f62ee4b9c5a]
#112  /lib64/libQt5WebKit.so.5(+0x13531b2) [0x7f62ee4b81b2]
#113  /lib64/libQt5WebKit.so.5(+0x16e6f69) [0x7f62ee84bf69]
#114  0x7f62ee850d69 in WebCore::EventHandler::handleMouseReleaseEvent(WebCore::PlatformMouseEvent const&) from /lib64/libQt5WebKit.so.5+0x529
#115  0x7f62ed735de6 in QWebPageAdapter::mouseReleaseEvent(QMouseEvent*) from /lib64/libQt5WebKit.so.5+0x76
#116  0x7f62f5e777eb in QWebPage::event(QEvent*) from /lib64/libQt5WebKitWidgets.so.5+0x96b
#117  0x7f62f5e78754 in QWebView::mouseReleaseEvent(QMouseEvent*) from /lib64/libQt5WebKitWidgets.so.5+0x24
#118  0x7f6362b1134e in QWidget::event(QEvent*) from /lib64/libQt5Widgets.so.5+0x24e
#119  0x7f62f5e79ea3 in QWebView::event(QEvent*) from /lib64/libQt5WebKitWidgets.so.5+0x63
#120  0x7f6362acead6 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x86
#121  0x7f6362ad83a3 in QApplication::notify(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x583
#122  0x7f6363d714e8 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x88
#123  0x7f63626a5df8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /lib64/libQt5Core.so.5+0x88
#124  0x7f6362ad74b7 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool, bool) from /lib64/libQt5Widgets.so.5+0x1b7
#125  /lib64/libQt5Widgets.so.5(+0x1ce0dd) [0x7f6362b2d0dd]


Expected results:
To open the file.

Additional info:
This seems to be new compared to the previous rpm.

Comment 1 Josh Cogliati 2020-01-07 19:39:52 UTC
Reverting to 0.18.4-2 solves this crash.

Comment 2 Josh Cogliati 2020-01-10 15:27:53 UTC
Note that this is still in freecad-0.18.4-4.fc31.x86_64

Start freecad, go to FemCalculixCantilever2D.FCStd

FreeCAD
FreeCAD 0.18, Libs: 0.18RUnknown
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2019
  #####                 ####  ###   ####  
  #                    #      # #   #   # 
  #     ##  #### ####  #     #   #  #   # 
  ####  # # #  # #  #  #     #####  #   # 
  #     #   #### ####  #    #     # #   # 
  #     #   #    #     #    #     # #   #  ##  ##  ##
  #     #   #### ####   ### #     # ####   ##  ##  ##

Coin read error: Type 'BadType' is not derived from 'BadType'
	Occurred at line   1 in <memory>
Camera settings failed to read
Program received signal SIGSEGV, Segmentation fault.
#0  /lib64/libc.so.6(+0x3c6b0) [0x7f28fc61e6b0]
#1  0x7f28fc1b8ecf in SoState::getElement(int) from /lib64/libCoin.so.80+0x15f
#2  0x7f28fc0c9bec in SoCacheElement::set(SoState*, SoCache*) from /lib64/libCoin.so.80+0x1c
#3  0x7f28fc209de4 in SoSeparator::getBoundingBox(SoGetBoundingBoxAction*) from /lib64/libCoin.so.80+0x464
#4  0x7f28fc1f8878 in SoNode::getBoundingBoxS(SoAction*, SoNode*) from /lib64/libCoin.so.80+0x48
#5  0x7f28fc00e837 in SoAction::traverse(SoNode*) from /lib64/libCoin.so.80+0x67
#6  0x7f28fc00ecda in SoAction::apply(SoNode*) from /lib64/libCoin.so.80+0x28a
#7  0x7f28fc2d0c52 in SoRenderManagerP::setClippingPlanes() from /lib64/libCoin.so.80+0x92
#8  0x7f28fc2fe0ed in SoDataSensor::trigger() from /lib64/libCoin.so.80+0xd
#9  0x7f28fc2ffda6 in SoSensorManager::processDelayQueue(int) from /lib64/libCoin.so.80+0x3c6
#10  0x7f28fe5396cc in SIM::Coin3D::Quarter::QuarterWidget::paintEvent(QPaintEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x1bc
#11  0x7f28fe5413f1 in SIM::Coin3D::Quarter::SoQTQuarterAdaptor::paintEvent(QPaintEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x21
#12  0x7f28fd0a7c7e in QWidget::event(QEvent*) from /lib64/libQt5Widgets.so.5+0x24e
#13  0x7f28fd156f62 in QFrame::event(QEvent*) from /lib64/libQt5Widgets.so.5+0x22
#14  0x7f28fd3c7381 in QGraphicsView::viewportEvent(QEvent*) from /lib64/libQt5Widgets.so.5+0x161
#15  0x7f28fe5397be in SIM::Coin3D::Quarter::QuarterWidget::viewportEvent(QEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x9e
#16  0x7f28fcc3129e in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) from /lib64/libQt5Core.so.5+0x9e
#17  0x7f28fd064aa5 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x75
#18  0x7f28fd06e150 in QApplication::notify(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x330
#19  0x7f28fe310548 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x88
#20  0x7f28fcc31458 in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /lib64/libQt5Core.so.5+0x88
#21  0x7f28fd0a095a in QWidgetPrivate::sendPaintEvent(QRegion const&) from /lib64/libQt5Widgets.so.5+0x3a
#22  0x7f28fd0a1199 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x7e9
#23  0x7f28fd0a1eb3 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4d3
#24  0x7f28fd0a0eac in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4fc
#25  0x7f28fd0a1eb3 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4d3
#26  0x7f28fd0a0eac in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4fc
#27  0x7f28fd0a1eb3 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4d3
#28  0x7f28fd0a0eac in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4fc
#29  0x7f28fd0a1eb3 in QWidgetPrivate::paintSiblingsRecursive(QPaintDevice*, QList<QObject*> const&, int, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4d3
#30  0x7f28fd0a0eac in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) from /lib64/libQt5Widgets.so.5+0x4fc
#31  /lib64/libQt5Widgets.so.5(+0x182476) [0x7f28fd077476]
#32  /lib64/libQt5Widgets.so.5(+0x182901) [0x7f28fd077901]
#33  0x7f28fd08fcc5 in QWidgetPrivate::syncBackingStore() from /lib64/libQt5Widgets.so.5+0xa5
#34  0x7f28fd0a8038 in QWidget::event(QEvent*) from /lib64/libQt5Widgets.so.5+0x608
#35  0x7f28fd1be838 in QMainWindow::event(QEvent*) from /lib64/libQt5Widgets.so.5+0x68
#36  0x7f28fe5d083b in Gui::MainWindow::event(QEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x18b
#37  0x7f28fd064ab6 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x86
#38  0x7f28fd06e150 in QApplication::notify(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x330
#39  0x7f28fe310548 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x88
#40  0x7f28fcc31458 in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /lib64/libQt5Core.so.5+0x88
#41  0x7f28fcc3449b in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) from /lib64/libQt5Core.so.5+0x14b
#42  /lib64/libQt5Widgets.so.5(+0x49d00b) [0x7f28fd39200b]
#43  /lib64/libQt5Widgets.so.5(+0x4a5a8b) [0x7f28fd39aa8b]
#44  0x7f28fcc5c80a in QObject::event(QEvent*) from /lib64/libQt5Core.so.5+0x22a
#45  0x7f28fd3a8d93 in QGraphicsScene::event(QEvent*) from /lib64/libQt5Widgets.so.5+0x93
#46  0x7f28fd064ab6 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x86
#47  0x7f28fd06e150 in QApplication::notify(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x330
#48  0x7f28fe310548 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x88
#49  0x7f28fcc31458 in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /lib64/libQt5Core.so.5+0x88
#50  0x7f28fcc3449b in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) from /lib64/libQt5Core.so.5+0x14b
#51  /lib64/libQt5Core.so.5(+0x2c5b07) [0x7f28fcc86b07]
#52  /lib64/libglib-2.0.so.0(g_main_context_dispatch+0x160) [0x7f28fa600510]
#53  /lib64/libglib-2.0.so.0(+0x518a0) [0x7f28fa6008a0]
#54  /lib64/libglib-2.0.so.0(g_main_context_iteration+0x33) [0x7f28fa600943]
#55  0x7f28fcc86914 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /lib64/libQt5Core.so.5+0xe4
#56  0x7f28fe5e1705 in Gui::Sequencer::setValue(int) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x1c5
#57  0x7f28fda38cf0 in Base::SequencerBase::next(bool) from /usr/lib64/freecad/lib/libFreeCADBase.so+0x70
#58  0x7f28fda39501 in Base::SequencerLauncher::next(bool) from /usr/lib64/freecad/lib/libFreeCADBase.so+0x61
#59  0x7f28fda2fc19 in Base::XMLReader::readFiles(zipios::ZipInputStream&) const from /usr/lib64/freecad/lib/libFreeCADBase.so+0x109
#60  0x7f28fdc612db in App::Document::restore() from /usr/lib64/freecad/lib/libFreeCADApp.so+0x36b
#61  0x7f28fdd7d704 in App::Application::openDocument(char const*) from /usr/lib64/freecad/lib/libFreeCADApp.so+0x194
#62  0x7f28fdd98d3d in App::Application::sOpenDocument(_object*, _object*) from /usr/lib64/freecad/lib/libFreeCADApp.so+0xad
#63  /lib64/libpython3.7m.so.1.0(_PyMethodDef_RawFastCallKeywords+0x25e) [0x7f28fd6ad61e]
#64  /lib64/libpython3.7m.so.1.0(_PyCFunction_FastCallKeywords+0x23) [0x7f28fd6ad753]
#65  /lib64/libpython3.7m.so.1.0(+0x141923) [0x7f28fd6e0923]
#66  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x55d2) [0x7f28fd71bc92]
#67  /lib64/libpython3.7m.so.1.0(_PyEval_EvalCodeWithName+0x2f0) [0x7f28fd6cdcb0]
#68  /lib64/libpython3.7m.so.1.0(PyEval_EvalCodeEx+0x39) [0x7f28fd6cea09]
#69  /lib64/libpython3.7m.so.1.0(PyEval_EvalCode+0x1b) [0x7f28fd75d53b]
#70  /lib64/libpython3.7m.so.1.0(+0x1ff333) [0x7f28fd79e333]
#71  /lib64/libpython3.7m.so.1.0(PyRun_StringFlags+0x7d) [0x7f28fd79e3cd]
#72  0x7f28fd9fedea in Base::InterpreterSingleton::runString[abi:cxx11](char const*) from /usr/lib64/freecad/lib/libFreeCADBase.so+0x6a
#73  0x7f28fdd985f7 in App::Application::sLoadFile(_object*, _object*) from /usr/lib64/freecad/lib/libFreeCADApp.so+0x567
#74  /lib64/libpython3.7m.so.1.0(_PyMethodDef_RawFastCallKeywords+0x25e) [0x7f28fd6ad61e]
#75  /lib64/libpython3.7m.so.1.0(_PyCFunction_FastCallKeywords+0x23) [0x7f28fd6ad753]
#76  /lib64/libpython3.7m.so.1.0(+0x141923) [0x7f28fd6e0923]
#77  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0x55d2) [0x7f28fd71bc92]
#78  /lib64/libpython3.7m.so.1.0(_PyEval_EvalCodeWithName+0x2f0) [0x7f28fd6cdcb0]
#79  /lib64/libpython3.7m.so.1.0(PyEval_EvalCodeEx+0x39) [0x7f28fd6cea09]
#80  /lib64/libpython3.7m.so.1.0(PyEval_EvalCode+0x1b) [0x7f28fd75d53b]
#81  /lib64/libpython3.7m.so.1.0(+0x1ff333) [0x7f28fd79e333]
#82  /lib64/libpython3.7m.so.1.0(PyRun_StringFlags+0x7d) [0x7f28fd79e3cd]
#83  /lib64/libpython3.7m.so.1.0(+0x1ff79b) [0x7f28fd79e79b]
#84  /lib64/libpython3.7m.so.1.0(_PyMethodDef_RawFastCallKeywords+0x74) [0x7f28fd6ad434]
#85  /lib64/libpython3.7m.so.1.0(_PyCFunction_FastCallKeywords+0x23) [0x7f28fd6ad753]
#86  /lib64/libpython3.7m.so.1.0(+0x141923) [0x7f28fd6e0923]
#87  /lib64/libpython3.7m.so.1.0(_PyEval_EvalFrameDefault+0xb59) [0x7f28fd717219]
#88  /lib64/libpython3.7m.so.1.0(_PyEval_EvalCodeWithName+0x2f0) [0x7f28fd6cdcb0]
#89  /lib64/libpython3.7m.so.1.0(PyEval_EvalCodeEx+0x39) [0x7f28fd6cea09]
#90  /lib64/libpython3.7m.so.1.0(PyEval_EvalCode+0x1b) [0x7f28fd75d53b]
#91  /lib64/libpython3.7m.so.1.0(+0x1ff333) [0x7f28fd79e333]
#92  /lib64/libpython3.7m.so.1.0(PyRun_StringFlags+0x7d) [0x7f28fd79e3cd]
#93  0x7f28fd9fedea in Base::InterpreterSingleton::runString[abi:cxx11](char const*) from /usr/lib64/freecad/lib/libFreeCADBase.so+0x6a
#94  0x7f28fe33c7e4 in Gui::Command::doCommand(Gui::Command::DoCmd_Type, char const*, ...) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x134
#95  0x7f28ec28df70 in WebGui::BrowserView::onLinkClicked(QUrl const&) from /usr/lib64/freecad/lib/WebGui.so+0x820
#96  0x7f28fcc5b98b in QMetaObject::activate(QObject*, int, int, void**) from /lib64/libQt5Core.so.5+0x67b
#97  0x7f28a838ed09 in QWebView::linkClicked(QUrl const&) from /lib64/libQt5WebKitWidgets.so.5+0x39
#98  /lib64/libQt5WebKitWidgets.so.5(+0x37baa) [0x7f28a838fbaa]
#99  0x7f28fcc5b98b in QMetaObject::activate(QObject*, int, int, void**) from /lib64/libQt5Core.so.5+0x67b
#100  0x7f28a83845b9 in QWebPage::linkClicked(QUrl const&) from /lib64/libQt5WebKitWidgets.so.5+0x39
#101  0x7f28a8384ceb in QWebPage::acceptNavigationRequest(QWebFrame*, QNetworkRequest const&, QWebPage::NavigationType) from /lib64/libQt5WebKitWidgets.so.5+0x8b
#102  /lib64/libQt5WebKit.so.5(+0x5aa000) [0x7f28a1710000]
#103  /lib64/libQt5WebKit.so.5(+0x166445e) [0x7f28a27ca45e]
#104  /lib64/libQt5WebKit.so.5(+0x16483f4) [0x7f28a27ae3f4]
#105  /lib64/libQt5WebKit.so.5(+0x1648a29) [0x7f28a27aea29]
#106  /lib64/libQt5WebKit.so.5(+0x16492e2) [0x7f28a27af2e2]
#107  0x7f28a27aff21 in WebCore::FrameLoader::loadFrameRequest(WebCore::FrameLoadRequest const&, WebCore::Event*, WTF::PassRefPtr<WebCore::FormState>) from /lib64/libQt5WebKit.so.5+0x3e1
#108  /lib64/libQt5WebKit.so.5(+0x164a4dc) [0x7f28a27b04dc]
#109  0x7f28a27b0a4a in WebCore::FrameLoader::urlSelected(WebCore::URL const&, WTF::String const&, WebCore::Event*, WebCore::LockHistory, WebCore::LockBackForwardList, WebCore::ShouldSendReferrer, WebCore::ShouldOpenExternalURLsPolicy) from /lib64/libQt5WebKit.so.5+0x3fa
#110  /lib64/libQt5WebKit.so.5(+0x11feea5) [0x7f28a2364ea5]
#111  /lib64/libQt5WebKit.so.5(+0x1354c4a) [0x7f28a24bac4a]
#112  /lib64/libQt5WebKit.so.5(+0x13531a2) [0x7f28a24b91a2]
#113  /lib64/libQt5WebKit.so.5(+0x16e6f59) [0x7f28a284cf59]
#114  0x7f28a2851d59 in WebCore::EventHandler::handleMouseReleaseEvent(WebCore::PlatformMouseEvent const&) from /lib64/libQt5WebKit.so.5+0x529
#115  0x7f28a1736dd6 in QWebPageAdapter::mouseReleaseEvent(QMouseEvent*) from /lib64/libQt5WebKit.so.5+0x76
#116  0x7f28a838d7eb in QWebPage::event(QEvent*) from /lib64/libQt5WebKitWidgets.so.5+0x96b
#117  0x7f28a838e754 in QWebView::mouseReleaseEvent(QMouseEvent*) from /lib64/libQt5WebKitWidgets.so.5+0x24
#118  0x7f28fd0a7c7e in QWidget::event(QEvent*) from /lib64/libQt5Widgets.so.5+0x24e
#119  0x7f28a838fea3 in QWebView::event(QEvent*) from /lib64/libQt5WebKitWidgets.so.5+0x63
#120  0x7f28fd064ab6 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x86
#121  0x7f28fd06e3a3 in QApplication::notify(QObject*, QEvent*) from /lib64/libQt5Widgets.so.5+0x583
#122  0x7f28fe310548 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib64/freecad/lib/libFreeCADGui.so+0x88
#123  0x7f28fcc31458 in QCoreApplication::notifyInternal2(QObject*, QEvent*) from /lib64/libQt5Core.so.5+0x88
#124  0x7f28fd06d4b7 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool, bool) from /lib64/libQt5Widgets.so.5+0x1b7
#125  /lib64/libQt5Widgets.so.5(+0x1cec8d) [0x7f28fd0c3c8d]

Comment 3 Fedora Update System 2020-01-17 14:23:52 UTC
FEDORA-2020-6840f47e41 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-6840f47e41

Comment 4 Fedora Update System 2020-01-17 14:23:54 UTC
FEDORA-2020-bb7ff34fc3 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-bb7ff34fc3

Comment 5 Fedora Update System 2020-01-18 01:25:29 UTC
freecad-0.18.4-5.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-6840f47e41

Comment 6 Fedora Update System 2020-01-18 01:44:17 UTC
freecad-0.18.4-5.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-bb7ff34fc3

Comment 7 Fedora Update System 2020-01-26 01:00:29 UTC
freecad-0.18.4-5.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2020-01-27 11:25:59 UTC
freecad-0.18.4-5.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.