Bug 1788705 - Performance: OLM icons take too long to load, blocking later pages
Summary: Performance: OLM icons take too long to load, blocking later pages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.2.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1779386 (view as bug list)
Depends On: 1788704
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-07 21:01 UTC by Samuel Padgett
Modified: 2020-01-22 10:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1788704
Environment:
Version: 4.4.0-0.ci-2020-01-06-112112 Cluster ID: 59267127-c40a-4dc7-8b7c-b9148db6ce39 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:71.0) Gecko/20100101 Firefox/71.0
Last Closed: 2020-01-22 10:46:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3885 None closed [release-4.2] Bug 1788705: Lazy load images in OperatorHub 2020-02-11 19:45:36 UTC
Red Hat Product Errata RHBA-2020:0107 None None None 2020-01-22 10:46:57 UTC

Description Samuel Padgett 2020-01-07 21:01:22 UTC
+++ This bug was initially created as a clone of Bug #1788704 +++

The OperatorHub subscribe flow is blocked until all images from the catalog load. Since we do code splitting, the request for the JS chunk for the next page is blocked because of the pending image requests. This has also caused timeouts in our OLM integration tests in CI.

Comment 1 Samuel Padgett 2020-01-07 21:02:57 UTC
*** Bug 1779386 has been marked as a duplicate of this bug. ***

Comment 3 XiaochuanWang 2020-01-13 06:21:17 UTC
Checked and verified on 4.2.14
When here are 169 items in the Operator Hub, user scroll up/down the page and can view them instantly and smoothly.

Comment 5 errata-xmlrpc 2020-01-22 10:46:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0107


Note You need to log in before you can comment on or make changes to this bug.