Bug 1788810 - "Custom" in label "flavor.template.kubevirt.io/Custom" should be in lowercase
Summary: "Custom" in label "flavor.template.kubevirt.io/Custom" should be in lowercase
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.5.0
Assignee: Filip Krepinsky
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-08 07:26 UTC by Guohua Ouyang
Modified: 2020-07-13 17:13 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Deprecated Functionality
Doc Text:
flavor.template.kubevirt.io/Custom label is no longer used to identify custom flavors
Clone Of:
Environment:
Last Closed: 2020-07-13 17:13:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5250 0 None closed Bug 1788810: deprecate usage of flavor.template.kubevirt.io/Custom label 2020-07-06 19:31:56 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:13:16 UTC

Description Guohua Ouyang 2020-01-08 07:26:26 UTC
Description of problem:
$ oc get vm test --show-labels
NAME   AGE   RUNNING   VOLUME   LABELS
test   10m   true               app=test,flavor.template.kubevirt.io/Custom=true,os.template.kubevirt.io/centos6.0=true,vm.kubevirt.io/template-namespace=default,vm.kubevirt.io/template.revision=1,vm.kubevirt.io/template.version=v0.8.1,vm.kubevirt.io/template=uploaddisk,workload.template.kubevirt.io/server=true


Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2020-01-06-005750

How reproducible:


Steps to Reproduce:
1. Create a VM with custom Flavor and then check the labels.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Tomas Jelinek 2020-01-15 11:53:01 UTC
@Guohua: Im not sure - why should it be lowercase?

Comment 2 Guohua Ouyang 2020-01-17 02:04:08 UTC
The whole page are lowercase except once letter is uppercase, I thought it should be lowercase for cosmetic.
If it's not necessary, free to close this bug.

Comment 3 Tomas Jelinek 2020-01-20 09:22:36 UTC
If it is just cosmetics I will close it for now. Changing it would mean that we should have some logic to handle VMs created before this change and also the ones after this change. Not too hard but I would like to avoid it if there is no practical reason for that.

Comment 4 Filip Krepinsky 2020-04-30 15:41:16 UTC
We have to align with vm-import-operator project which will be using this label as well in lowercase variant: https://github.com/kubevirt/vm-import-operator/pull/168

We can add logic to our UI to accept both legacy 'Custom and new 'custom' labels. We should also fallback to Custom when this label is missing

Comment 5 Filip Krepinsky 2020-05-04 12:14:48 UTC
We concluded that there is no value in having this label as it is not supported by common templates. We should fallback to the same behaviour as when we the label is missing. We should remove the use of this label in the UI and in vm-import-operator.

Comment 9 Radim Hrazdil 2020-05-20 14:21:33 UTC
Verified that the label is not used anymore.
Verified in console release-4.5 branch commit: 5994c64ee529b650bae348ef78ebc23dca8db5c5

Comment 11 errata-xmlrpc 2020-07-13 17:13:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.