Bug 178883 - update to 4.1.4-15 changed auto.master
update to 4.1.4-15 changed auto.master
Status: CLOSED DUPLICATE of bug 178474
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-25 01:39 EST by Patrick C. F. Ernzer
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-25 08:11:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick C. F. Ernzer 2006-01-25 01:39:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
not sure if this was intended or not, it sure was unexpected.

When I did a 'yum update' that brought autofs up to 4.1.4-15 from whatever was the version before on FC4, my /etc/auto.master got changed.

No /etc/auto.master.rpmnew, nor .rpmold was created on any of the 3 affected systems

No biggie, but it might annoy some of our users

Version-Release number of selected component (if applicable):
autofs-4.1.4-15

How reproducible:
Always

Steps to Reproduce:
0. Have FC4
1. have a /etc/auto.master that contains an active line with "/misc   /etc/auto.misc --timeout=60"
2. yum update (brought autofs up to 4.1.4-15 on 2006-01-20)
3. try using /misc/banana some time later with a script that must have the device mounted ro (the only reason I even use autofs with USB sticks)
  

Actual Results:  script nags, No such file or directory.

Expected Results:  autofs not to change auto.master

Additional info:

obviously the fix is quick and straightforward, but it affects quite a few of my machines.

BTW: If you wonder what I do in that script:
  a) umount USB stick that was mounted automagically
  b) access it over autofs (entry contains 'ro' option')
  c) ssh-add some ssh key from that stick

As the stick is fat-formatted, I cannot chmod 600 the ssh pubkey, and without mounting the stick ro ssh-add will (quite rightly) refuse to add the key, plus I can just rip out the stick without worrying about the filesystem on it.
Comment 1 Jeffrey Moyer 2006-01-25 08:11:16 EST
I was asked to remove this from the default maps, as it is primarily used for
cdrom mounting, and there are better means to achieve that.

The reason your auto.master was replaced is because you did not modify the
original configuration file.  The spec file lists auto.master as a
%config(noreplace).

Sorry for the inconvenience.

*** This bug has been marked as a duplicate of 178474 ***

Note You need to log in before you can comment on or make changes to this bug.