Bug 178898 - (LDAPaliases) Directory Server should support LDAP aliases
Directory Server should support LDAP aliases
Status: CLOSED DEFERRED
Product: 389
Classification: Community
Component: Directory Server (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Ben Levenson
: FutureFeature
Depends On:
Blocks: 389_1.3.0 512820 690319
  Show dependency treegraph
 
Reported: 2006-01-25 06:00 EST by Gerard Zonjee
Modified: 2015-11-19 18:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 18:12:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gerard Zonjee 2006-01-25 06:00:56 EST
Description of problem:

The Fedora Directory Server does not honor alias dereferencing requests

Version-Release number of selected component (if applicable): 
Fedora Directory Server 1.0.1


How reproducible:
An ldapsearch using the correct '-a' syntax

Steps to Reproduce:
# ldapsearch -a always -x -b
'uid=myuser,ou=Accounts,ou=Office,dc=company,dc=com' -s base -h
ns-slapd.company.com 'uid=myuser' 'uid'   

dn: uid=myuser,ou=Accounts,ou=Office,dc=company,dc=com
uid: myuser  

Expected results:
# ldapsearch -a always -x -b
'uid=myuser,ou=Accounts,ou=Office,dc=company,dc=com' -s base -h
openldap.company.com 'uid=myuser' 'uid' 

dn: cn=My User,ou=Persons,ou=Office,dc=company,dc=com
uid: myuser

Additional info: using the openldap ldapsearch or fedora provided ldapsearch
from /opt/fedora-ds/shared/bin does not make a difference. The fedora ds server
does not honor the -a setting, nor any -a setting (find, search or always) and
handles it by the default -never setting.
Comment 1 Henny Bekker 2006-01-25 10:13:34 EST
The same custruct with OpenLDAP slapd server v2.0.27-20 does work ok..
Comment 2 Rich Megginson 2006-01-25 10:18:42 EST
You are correct.  Fedora DS does not support aliases.  We will investigate
adding support for aliases to a future release of Fedora DS.
Comment 3 Martin Kosek 2012-01-04 08:50:37 EST
Upstream ticket:
https://fedorahosted.org/389/ticket/152
Comment 5 Noriko Hosoi 2015-11-19 18:12:27 EST
Closing this bug since we moved to the ticket system:
https://fedorahosted.org/389/ticket/152

Note You need to log in before you can comment on or make changes to this bug.