Bug 1789016 - Convert KubeAPILatencyHigh to use anomaly detection
Summary: Convert KubeAPILatencyHigh to use anomaly detection
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.1.z
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Pawel Krupa
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks: 1789023
TreeView+ depends on / blocked
 
Reported: 2020-01-08 15:19 UTC by Pawel Krupa
Modified: 2020-05-04 11:23 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1789023 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:23:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github kubernetes-monitoring kubernetes-mixin pull 304 0 None closed apply simple anomaly detectionto KubeAPILatencyHigh alert 2020-10-15 07:01:55 UTC
Github openshift cluster-monitoring-operator pull 588 0 None closed jsonnet: bump kubernetes-mixin 2020-10-15 07:01:55 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:23:40 UTC

Description Pawel Krupa 2020-01-08 15:19:57 UTC
A solution to https://bugzilla.redhat.com/show_bug.cgi?id=1743911

Description of problem:
KubeAPILatencyHigh alert can be triggered when there is a long-running, resource-intensive job. A solution would be to apply https://prometheus.io/blog/2015/06/18/practical-anomaly-detection/

Version-Release number of selected component (if applicable):


How reproducible:
The resolution of the alert is very consistent and I can show data from specific clusters where resolution occurs within 10 minutes of the alert triggering.

Steps to Reproduce:
1. Unknown
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 errata-xmlrpc 2020-05-04 11:23:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.