Bug 1789053 - [abrt] python3-caribou: _load_style(): keyboard_view.py:297:_load_style:gi.repository.GLib.GError: gtk-css-provider-error-quark: style.css:16:8not a number (1)
Summary: [abrt] python3-caribou: _load_style(): keyboard_view.py:297:_load_style:gi.re...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: caribou
Version: 31
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: leigh scott
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:87961755f599209f35d4b09b0bf...
: 1789062 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-08 16:11 UTC by Ulrich Prager
Modified: 2020-01-24 17:43 UTC (History)
3 users (show)

Fixed In Version: caribou-0.4.21-19.fc30 caribou-0.4.21-19.fc31 caribou-0.4.21-18.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-19 01:00:34 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.97 KB, text/plain)
2020-01-08 16:11 UTC, Ulrich Prager
no flags Details
File: cpuinfo (2.43 KB, text/plain)
2020-01-08 16:11 UTC, Ulrich Prager
no flags Details
File: environ (1.58 KB, text/plain)
2020-01-08 16:11 UTC, Ulrich Prager
no flags Details
File: mountinfo (2.64 KB, text/plain)
2020-01-08 16:11 UTC, Ulrich Prager
no flags Details
File: namespaces (129 bytes, text/plain)
2020-01-08 16:11 UTC, Ulrich Prager
no flags Details
File: open_fds (1.19 KB, text/plain)
2020-01-08 16:11 UTC, Ulrich Prager
no flags Details

Description Ulrich Prager 2020-01-08 16:11:23 UTC
Version-Release number of selected component:
python3-caribou-0.4.21-15.fc31

Additional info:
reporter:       libreport-2.11.3
cgroup:         0::/user.slice/user-1000.slice/user@1000.service/dbus\x2d:1.2\x2dorg.gnome.Caribou.Keyboard.slice/dbus-:1.2-org.gnome.Caribou.Keyboard@0.service
cmdline:        python3 -m caribou.antler.main
crash_function: _load_style
exception_type: gi.repository.GLib.GError
executable:     /usr/lib/python3.7/site-packages/caribou/antler/main.py
interpreter:    python3-3.7.5-2.fc31.x86_64
kernel:         5.4.7-200.fc31.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
keyboard_view.py:297:_load_style:gi.repository.GLib.GError: gtk-css-provider-error-quark: style.css:16:8not a number (1)

Traceback (most recent call last):
  File "/usr/lib64/python3.7/runpy.py", line 193, in _run_module_as_main
    "__main__", mod_spec)
  File "/usr/lib64/python3.7/runpy.py", line 85, in _run_code
    exec(code, run_globals)
  File "/usr/lib/python3.7/site-packages/caribou/antler/main.py", line 71, in <module>
    command(args).run()
  File "/usr/lib/python3.7/site-packages/caribou/antler/main.py", line 17, in __init__
    self.window = AntlerWindowEntry(AntlerKeyboardView)
  File "/usr/lib/python3.7/site-packages/caribou/antler/window.py", line 413, in __init__
    AntlerWindow.__init__(self, keyboard_view_factory, placement)
  File "/usr/lib/python3.7/site-packages/caribou/antler/window.py", line 225, in __init__
    self.keyboard_view = keyboard_view_factory (keyboard_type=settings.keyboard_type.value)
  File "/usr/lib/python3.7/site-packages/caribou/antler/keyboard_view.py", line 233, in __init__
    [GLib.get_user_data_dir()] + list(GLib.get_system_data_dirs()))
  File "/usr/lib/python3.7/site-packages/caribou/antler/keyboard_view.py", line 297, in _load_style
    provider.load_from_path(fn)
gi.repository.GLib.GError: gtk-css-provider-error-quark: style.css:16:8not a number (1)

Local variables in innermost frame:
self: <keyboard_view.AntlerKeyboardView object at 0x7fa0c074deb0 (caribou+antler+keyboard_view+AntlerKeyboardView at 0x55ec2b9fe270)>
provider: <Gtk.CssProvider object at 0x7fa0c0751460 (GtkCssProvider at 0x7fa0a0005a20)>
filename: 'style.css'
search_path: ['/home/ulrichp/.local/share', '/usr/share', '/home/ulrichp/.local/share/flatpak/exports/share/', '/var/lib/flatpak/exports/share/', '/usr/local/share/', '/usr/share/']
spath: ['/home/ulrichp/.local/share', '/usr/share', '/home/ulrichp/.local/share/flatpak/exports/share/', '/var/lib/flatpak/exports/share/', '/usr/local/share/', '/usr/share/']
directory: '/usr/share'
fn: '/usr/share/antler/style.css'

Comment 1 Ulrich Prager 2020-01-08 16:11:26 UTC
Created attachment 1650773 [details]
File: backtrace

Comment 2 Ulrich Prager 2020-01-08 16:11:28 UTC
Created attachment 1650774 [details]
File: cpuinfo

Comment 3 Ulrich Prager 2020-01-08 16:11:29 UTC
Created attachment 1650775 [details]
File: environ

Comment 4 Ulrich Prager 2020-01-08 16:11:31 UTC
Created attachment 1650776 [details]
File: mountinfo

Comment 5 Ulrich Prager 2020-01-08 16:11:32 UTC
Created attachment 1650777 [details]
File: namespaces

Comment 6 Ulrich Prager 2020-01-08 16:11:35 UTC
Created attachment 1650778 [details]
File: open_fds

Comment 7 Ulrich Prager 2020-01-08 16:15:37 UTC
*** Bug 1789062 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2020-01-08 16:58:40 UTC
FEDORA-EPEL-2020-d53537a260 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-d53537a260

Comment 9 Fedora Update System 2020-01-08 16:58:43 UTC
FEDORA-2020-c1303ef75d has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-c1303ef75d

Comment 10 Fedora Update System 2020-01-08 16:58:44 UTC
FEDORA-2020-d68c359b3f has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-d68c359b3f

Comment 11 Fedora Update System 2020-01-09 01:07:57 UTC
caribou-0.4.21-18.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-c1303ef75d

Comment 12 Fedora Update System 2020-01-09 01:45:58 UTC
caribou-0.4.21-18.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-d68c359b3f

Comment 13 Fedora Update System 2020-01-09 01:53:43 UTC
caribou-0.4.21-18.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-d53537a260

Comment 14 Fedora Update System 2020-01-11 01:24:58 UTC
caribou-0.4.21-19.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-d2c32deb7a

Comment 15 Fedora Update System 2020-01-11 01:48:40 UTC
caribou-0.4.21-19.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-cc041c4c76

Comment 16 Fedora Update System 2020-01-19 01:00:34 UTC
caribou-0.4.21-19.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2020-01-20 01:43:22 UTC
caribou-0.4.21-19.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2020-01-24 17:43:20 UTC
caribou-0.4.21-18.el8 has been pushed to the Fedora EPEL 8 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.