Bug 178907 - No sound with "Creative Labs SB Audigy LS"
No sound with "Creative Labs SB Audigy LS"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-25 06:27 EST by Thomas M Steenholdt
Modified: 2015-01-04 17:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 01:06:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of lspci -vv on the system in question (12.26 KB, text/plain)
2006-01-25 06:28 EST, Thomas M Steenholdt
no flags Details
output of lsmod on the system in question (2.18 KB, text/plain)
2006-01-25 06:29 EST, Thomas M Steenholdt
no flags Details

  None (edit)
Description Thomas M Steenholdt 2006-01-25 06:27:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060123 Fedora/1.5.0.1rc1-0.tmus.1 Firefox/1.5.0.1

Description of problem:
I have a Shuttle SD11G5 with SB Audigy LS built in.

There is just no sound!


Version-Release number of selected component (if applicable):
kernel-2.6.15-1.1871_FC5

How reproducible:
Always

Steps to Reproduce:
1. install FC rawhide on a similar system
2. wait for sound

  

Actual Results:  nothing

Expected Results:  we should have been surprised how great it sounds.

Additional info:
Comment 1 Thomas M Steenholdt 2006-01-25 06:28:23 EST
Created attachment 123661 [details]
output of lspci -vv on the system in question
Comment 2 Thomas M Steenholdt 2006-01-25 06:29:25 EST
Created attachment 123662 [details]
output of lsmod on the system in question
Comment 3 Thomas M Steenholdt 2006-01-25 06:31:57 EST
thought the contents of my modprobe.conf might be of interest, so here it is!

[root@n-a4831aa7936b4 ~]# cat /etc/modprobe.conf
alias eth0 tg3
alias scsi_hostadapter ata_piix
alias snd-card-0 snd-ca0106
options snd-card-0 index=0
options snd-ca0106 index=0
remove snd-ca0106 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-ca0106

let me know if I can provide you with any more info!

I DID confirm that sound actually works on the box.
Comment 4 Thomas M Steenholdt 2006-02-18 04:21:36 EST
It seems like the drivers/kernel are actually working fine and the problem is
nothing more than a default mixer setting (could be that default are made in the
hardware, i don't know)

As it turns out, MUTING IEC958 output, makes normal(analog) sound work just fine.

The command that makes this work for me is:

    amixer -c 0 sset IEC958,0 mute

I'm moving this bug til Anaconda, since I'm not entirely sure who is genaring
the default alsa configuration, but know it done during installation.

It may be that I just need to accept the defaults since they are determined
elsewhere, but it seems like effectively disabling ANALOG output by default is
not quite the right thing to do (not in 2006 anyways) :o)

Let me know what you think
Comment 5 Thomas M Steenholdt 2006-02-18 04:22:46 EST
Oh, and since this does not seem to be kernel related at all, all the newer
kernel versions exhibit the same behaviour - of course!
Comment 6 Thomas M Steenholdt 2006-02-18 04:45:49 EST
For the sake of completenes, i've had to change the preferences of the volume
control applet to use "CA0106 (Alsa Mixer)" as the device and "Analog Front" as
the track to control... Defaults were different, but i'm not sure of exactly how
things were before i started fiddling.

These changes also make sense to me, as normally i'd expect that the volume
control of my desktop OS to control my front speakers. 

Makes sense to you guys too?
Comment 7 Thomas M Steenholdt 2006-02-21 01:06:12 EST
This is working out-of-the-box in FC5test3, closing...

I'm closing as RAWHIDE since I don't know which component or version for sure.
There is a chance this has been fixed in anaconda for a while or something which
is only taking effect on reinstallation.
Comment 8 Miloš Komarčević 2006-03-25 14:23:18 EST
I'm still seeing weird behaviour in FC5 final. This is i386 version installed on
a MSI K8N Diamond with Athlon64 and SB Live 24.

To get any sound out of the system, Digital-1 on the OSS device needs to be
muted (wth???), while the IEC958 checkbox on the ALSA device needs to be off.
The only volume control that gives any change is Analog Front, but at least it's
something.

However, there's a big problem with OSS apps: you can't control the volume, and
RealPlayer e.g. becomes a real CPU hog for some reason, only reacts every few
seconds or so...

Note You need to log in before you can comment on or make changes to this bug.