Bug 1789091 - [ceph-ansible] : FS to BS migration - journal argument appended while configuring bluestore
Summary: [ceph-ansible] : FS to BS migration - journal argument appended while configu...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 4.0
Assignee: Guillaume Abrioux
QA Contact: Vasishta
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-08 17:38 UTC by Vasishta
Modified: 2020-01-31 12:48 UTC (History)
7 users (show)

Fixed In Version: ceph-ansible-4.0.7-1.el8cp, ceph-ansible-4.0.7-1.el7cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:48:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 4892 0 None closed ceph_volume: support filestore to bluestore migration (bp #4889) 2020-03-16 06:45:38 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:48:49 UTC

Description Vasishta 2020-01-08 17:38:17 UTC
Description of problem:
While migrating from filestore to bluestore, 'journal' argument was appended with ceph-volume command during bluestore OSD creation 

Version-Release number of selected component (if applicable):
ceph-ansible-4.0.6-1

Steps to Reproduce:
1. Configure 3.x cluster with filestore OSDs (tried scenario in which usr creates lvm and sets the variables lvm_volumes
2. Upgrade cluster to 4.x
3. run fs to bs migration playbook

Actual results:
Obeserved this command in ceph-ansible log     
 ceph
- lvm
- prepare
- --bluestore
- --data
- data_vg/data_lv2
- --journal
- j_vg/j2

Expected results:
relevant command must be generated

Comment 4 Vasishta 2020-01-13 09:17:08 UTC
Working fine with ceph-ansible-4.0.8-1.el7cp.noarch

ceph
  - lvm
  - prepare
  - --bluestore
  - --data
  - data_vg/data_lv1
  - --dmcrypt

Moving to VERIFIED state.

Comment 6 errata-xmlrpc 2020-01-31 12:48:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.