Bug 1789121 - Router doesn't listen on ipv6 interfaces when cluster network config indicates ipv6 support
Summary: Router doesn't listen on ipv6 interfaces when cluster network config indicate...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Dan Mace
QA Contact: Hongan Li
URL:
Whiteboard: ipv6
Depends On:
Blocks: 1789124
TreeView+ depends on / blocked
 
Reported: 2020-01-08 19:37 UTC by Dan Mace
Modified: 2020-05-04 11:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1789124 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:23:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-ingress-operator pull 342 None closed Bug 1789121: Configure router for IPv6 2020-05-26 14:52:26 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:23:54 UTC

Description Dan Mace 2020-01-08 19:37:48 UTC
Description of problem:

When running on an IPv6-enabled cluster (defined as the presence of an ipv6 address in the network.config.openshift.io `.status.clusterNetwork` list), the router isn't listening on an ipv6 address.

This has already been fixed in https://github.com/openshift/cluster-ingress-operator/pull/342 but we'd like to backport the fix and document the change with a bug report.

Version-Release number of selected component (if applicable):


How reproducible:

Launch a single-stack IPv6 enabled cluster on AWS without the fix.

Actual results:


The router process won't listen on any ipv6 interface.

Expected results:

The router should listen on all available ipv4 and ipv6 interfaces.

Additional info:

Comment 2 Russell Bryant 2020-01-28 21:25:19 UTC
I have tested this successfully

Comment 4 errata-xmlrpc 2020-05-04 11:23:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.