Bug 1789266 - Wrong command examples in "oc secrets new --help"
Summary: Wrong command examples in "oc secrets new --help"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.4.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-09 08:32 UTC by Liang Xia
Modified: 2020-05-04 11:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:23:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift oc pull 271 None closed Bug 1789266: remove deprecated oc secret sub-commands 2020-04-22 09:56:42 UTC
Github openshift origin pull 24466 None closed Bug 1789266: replace deprecated commands with current secrets commands 2020-04-22 09:56:42 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:23:54 UTC

Description Liang Xia 2020-01-09 08:32:38 UTC
Description of problem:
Wrong command examples in "oc secrets new --help"

Version-Release number of selected component (if applicable):
$ rpm -q openshift-clients
openshift-clients-4.3.0-202001030600.git.1.5e09fe6.el7.x86_64
$ oc version --client -o yaml
clientVersion:
  buildDate: "2020-01-03T06:08:27Z"
  compiler: gc
  gitCommit: 6a937dfe56ff26255d09702c69b8406040c14505
  gitTreeState: clean
  gitVersion: v4.3.0
  goVersion: go1.12.12
  major: ""
  minor: ""
  platform: linux/amd64


How reproducible:
Always

Steps to Reproduce:
1. Run command "oc secrets new --help"


Actual results:
Wrong command used in examples.
------------------------------------------------------------------------------------
Examples:
  # Create a new secret named my-secret with a key named ssh-privatekey
  oc my-secret ~/.ssh/ssh-privatekey
  
  # Create a new secret named my-secret with keys named ssh-privatekey and ssh-publickey instead of the names of the
keys on disk
  oc my-secret ssh-privatekey=~/.ssh/id_rsa ssh-publickey=~/.ssh/id_rsa.pub
  
  # Create a new secret named my-secret with keys for each file in the folder "bar"
  oc my-secret path/to/bar
  
  # Create a new .dockercfg secret named my-secret
  oc my-secret path/to/.dockercfg
  
  # Create a new .docker/config.json secret named my-secret
  oc my-secret .dockerconfigjson=path/to/.docker/config.json
------------------------------------------------------------------------------------

Expected results:
Examples use correct commands.

Additional info:

Comment 2 zhou ying 2020-02-11 01:45:51 UTC
Can't reproduce the issue now:
[root@localhost ~]# oc version -o yaml 
clientVersion:
  buildDate: "2020-02-10T17:21:47Z"
  compiler: gc
  gitCommit: ee05f83cb8f0bee84c0a1516591437cd71befdc8
  gitTreeState: clean
  gitVersion: v4.4.0
  goVersion: go1.13.4
  major: ""
  minor: ""
  platform: linux/amd64

[root@localhost ~]# oc secret new -h
Manage secrets in your project

 Secrets are used to store confidential information that should not be contained inside of an image. They are commonly
used to hold things like keys for authentication to other internal systems like container image registries.

Aliases:
secrets, secret

Usage:
  oc secrets [flags]

Available Commands:
  link        Link secrets to a ServiceAccount
  unlink      Detach secrets from a ServiceAccount

Use "oc <command> --help" for more information about a given command.
Use "oc options" for a list of global command-line options (applies to all commands).

Comment 4 errata-xmlrpc 2020-05-04 11:23:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.