Bug 1789269 - Boot order is "Not available" in vm template overview
Summary: Boot order is "Not available" in vm template overview
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.4.0
Assignee: Tomas Jelinek
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-09 08:42 UTC by Guohua Ouyang
Modified: 2020-05-04 11:23 UTC (History)
2 users (show)

Fixed In Version: 4.4.0-0.nightly-2020-01-13-010304
Doc Type: Bug Fix
Doc Text:
Cause: vm template overview page was not able to find the boot order in template yaml Consequence: if the user wanted to check the boot order, he could not use the visual editor but had to use the yaml editor Fix: corrected the way the boot order is parsed on the template overview page Result: the user can check and modify the boot order in a visual dialog
Clone Of:
Environment:
Last Closed: 2020-05-04 11:23:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:23:54 UTC

Description Guohua Ouyang 2020-01-09 08:42:11 UTC
Description of problem:
Boot order is "Not available" in vm template overview. Check the template yaml, the bootOrder is there.

vm template yaml snippet:
---
spec:
          domain:
            cpu:
              cores: 1
              sockets: 1
              threads: 1
            devices:
              networkInterfaceMultiqueue: true
              rng: {}
              interfaces:
                - name: nic0
                  model: virtio
                  bootOrder: 2
                  masquerade: {}
              disks:
                - name: rootdisk
                  bootOrder: 1
                  disk:
                    bus: virtio
---

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2020-01-06-005750

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Tomas Jelinek 2020-01-13 12:04:42 UTC
This already works on current master. Since it is low/low moving to 4.4 to on_qa

Comment 3 Guohua Ouyang 2020-02-18 08:36:37 UTC
verified on 4.4.0-0.nightly-2020-02-10-111955.

Comment 6 errata-xmlrpc 2020-05-04 11:23:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.