Bug 1789277 - Unable to deploy gluster using the hyperconverged wizard
Summary: Unable to deploy gluster using the hyperconverged wizard
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: gluster-ansible
Version: 0.14.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.4.0
: 0.14.2
Assignee: Gobinda Das
QA Contact: SATHEESARAN
URL:
Whiteboard:
: 1806298 (view as bug list)
Depends On:
Blocks: 1802004
TreeView+ depends on / blocked
 
Reported: 2020-01-09 09:07 UTC by admin
Modified: 2020-05-20 20:01 UTC (History)
3 users (show)

Fixed In Version: cockpit-ovirt-0.14.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1802004 (view as bug list)
Environment:
Last Closed: 2020-05-20 20:01:11 UTC
oVirt Team: Gluster
sbonazzo: ovirt-4.4?
sbonazzo: planning_ack?
sbonazzo: devel_ack+
sasundar: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 106890 0 master MERGED Fixed hostname validation issue 2020-03-30 07:51:47 UTC

Description admin 2020-01-09 09:07:37 UTC
Description of problem:
Gluster deployment wizard fails on "Check if provided hostnames are valid"

Version-Release number of selected component (if applicable):
ovirt-node-ng-4.4.0-0.20200109.0

How reproducible:
Same result when running wizard on any of the three nodes.

Steps to Reproduce:
1. Set up 3 oVirt nodes
2. Set up ssh-key on node 1 and copy to other nodes
3. Connect to admin console on node 1 and run hyperconverged deployment wizard

Actual results:
TASK [Check if provided hostnames are valid] ***********************************
task path: /usr/share/cockpit/ovirt-dashboard/ansible/hc_wizard.yml:29
fatal: [ovirt1.mylab]: FAILED! => {"msg": "The conditional check 'result.results[0]['stdout_lines'] > 0' failed. The error was: Unexpected templating type error occurred on ({% if result.results[0]['stdout_lines'] > 0 %} True {% else %} False {% endif %}): '>' not supported between instances of 'list' and 'int'"}
fatal: [ovirt3.mylab]: FAILED! => {"msg": "The conditional check 'result.results[0]['stdout_lines'] > 0' failed. The error was: Unexpected templating type error occurred on ({% if result.results[0]['stdout_lines'] > 0 %} True {% else %} False {% endif %}): '>' not supported between instances of 'list' and 'int'"}
fatal: [ovirt2.mylab]: FAILED! => {"msg": "The conditional check 'result.results[0]['stdout_lines'] > 0' failed. The error was: Unexpected templating type error occurred on ({% if result.results[0]['stdout_lines'] > 0 %} True {% else %} False {% endif %}): '>' not supported between instances of 'list' and 'int'"}

Expected results:
Hostnames are valid

Additional info:
 -on ovirt1 node:

# getent ahosts ovirt1.mylab
10.10.1.32       STREAM localhost
10.10.1.32       DGRAM  
10.10.1.32       RAW 

# getent ahosts ovirt2.mylab
10.10.1.34      STREAM ovirt2.mylab
10.10.1.34      DGRAM  
10.10.1.34      RAW 

# getent ahosts ovirt3.mylab
10.10.1.35      STREAM ovirt3.mylab
10.10.1.35      DGRAM  
10.10.1.35      RAW

Comment 1 admin 2020-01-09 09:12:06 UTC
Edit:
10.10.1.32       STREAM localhost
is actually
10.10.1.32       STREAM ovirt1.mylab

(I was testing different /etc/hosts configurations at the time to try and fix the problem and pasted the wrong output)

Comment 2 pestaa 2020-02-11 22:30:09 UTC
Affects me too.

I changed
          - "result.results[0]['stdout_lines'] > 0"
to
          - "result.results[0]['stdout_lines']|length > 0"
at /usr/share/cockpit/ovirt-dashboard/ansible/hc_wizard.yml:29.

Comment 3 Gobinda Das 2020-02-12 06:01:17 UTC
Issue is fixed in https://gerrit.ovirt.org/#/c/106890/  patch

Comment 4 Gal Zaidman 2020-02-24 07:41:03 UTC
*** Bug 1806298 has been marked as a duplicate of this bug. ***

Comment 5 SATHEESARAN 2020-03-30 07:52:36 UTC
Tested with cockpit-ovirt-dashboard-0.14.3
HC deployment ( only gluster deployment ) is successful with ovirt-ng node 4.4 based on el8.2

Comment 6 Sandro Bonazzola 2020-05-20 20:01:11 UTC
This bugzilla is included in oVirt 4.4.0 release, published on May 20th 2020.

Since the problem described in this bug report should be
resolved in oVirt 4.4.0 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.