Bug 1789364 (CVE-2019-19926) - CVE-2019-19926 sqlite: error mishandling because of incomplete fix of CVE-2019-19880
Summary: CVE-2019-19926 sqlite: error mishandling because of incomplete fix of CVE-201...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2019-19926
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1789365 1789367 1789368 1789369 1789373 1789374 1789377 1789381 1801837
Blocks: 1789370
TreeView+ depends on / blocked
 
Reported: 2020-01-09 12:54 UTC by msiddiqu
Modified: 2021-02-16 20:47 UTC (History)
32 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-15 08:09:30 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2020:0514 0 None None None 2020-02-17 08:29:57 UTC

Description msiddiqu 2020-01-09 12:54:04 UTC
multiSelect in select.c in SQLite 3.30.1 mishandles certain errors during parsing, as demonstrated by errors from sqlite3WindowRewrite() calls. NOTE: this vulnerability exists because of an incomplete fix for CVE-2019-19880. 

Upstream commit:

https://github.com/sqlite/sqlite/commit/8428b3b437569338a9d1e10c4cd8154acbe33089

Comment 1 msiddiqu 2020-01-09 12:56:06 UTC
Created libsqlite3x tracking bugs for this issue:

Affects: epel-all [bug 1789374]


Created mingw-libsqlite3x tracking bugs for this issue:

Affects: fedora-all [bug 1789365]


Created mingw-sqlite tracking bugs for this issue:

Affects: epel-7 [bug 1789377]
Affects: fedora-all [bug 1789367]


Created nodejs-sqlite3 tracking bugs for this issue:

Affects: fedora-all [bug 1789371]


Created rubygem-sqlite3 tracking bugs for this issue:

Affects: epel-7 [bug 1789375]
Affects: fedora-all [bug 1789372]


Created rubygem-sqlite3-ruby tracking bugs for this issue:

Affects: epel-6 [bug 1789376]


Created sqlite tracking bugs for this issue:

Affects: fedora-all [bug 1789368]


Created sqlite2 tracking bugs for this issue:

Affects: epel-all [bug 1789373]
Affects: fedora-all [bug 1789369]

Comment 2 msiddiqu 2020-01-09 12:59:30 UTC
Created libsqlite3x tracking bugs for this issue:

Affects: fedora-all [bug 1789381]

Comment 3 Vít Ondruch 2020-01-09 14:05:27 UTC
Similarly to nodejs-sqlite3, rubygem-sqlite3 dynamically links to libsqlite3, therefore it is not vulnerable itself. Could you please be more considerate with reporting such bugs? Thank you.

Comment 4 Huzaifa S. Sidhpurwala 2020-01-10 06:21:12 UTC
Statement:

This vulnerability exists because of an incomplete fix for CVE-2019-19880.  Currently Red Hat Products shipping sqlite have not fixed CVE-2019-19880 and therefore are not affected by this flaw.

Comment 6 Product Security DevOps Team 2020-01-15 08:09:30 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2019-19926

Comment 7 errata-xmlrpc 2020-02-17 08:24:44 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 6 Supplementary

Via RHSA-2020:0514 https://access.redhat.com/errata/RHSA-2020:0514

Comment 8 errata-xmlrpc 2020-02-17 08:29:48 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 6 Supplementary

Via RHSA-2020:0514 https://access.redhat.com/errata/RHSA-2020:0514


Note You need to log in before you can comment on or make changes to this bug.