Bug 1789421 - [4.3] ipv6 single stack config for kube-apiserver
Summary: [4.3] ipv6 single stack config for kube-apiserver
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.z
Assignee: Michal Fojtik
QA Contact: Ke Wang
URL:
Whiteboard:
Depends On: 1789420 1796618
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-09 14:39 UTC by Dan Winship
Modified: 2020-06-17 20:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1789420
Environment:
Last Closed: 2020-06-17 20:27:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-kube-apiserver-operator pull 710 None closed Bug 1789421: [release-4.3] If the cluster is single-stack IPv6, bind to :: rather than 0.0.0.0. 2020-06-01 03:15:19 UTC
Red Hat Product Errata RHBA-2020:2436 None None None 2020-06-17 20:28:20 UTC

Description Dan Winship 2020-01-09 14:39:37 UTC
+++ This bug was initially created as a clone of Bug #1789420 +++

In a single-stack IPv6 environment cluster-kube-apiserver-operator needs to generate the correct config for kube-apiserver.

--- Additional comment from Dan Winship on 2020-01-09 09:38:32 EST ---

Tested in the ipv6 builds. Not currently QA-able.

Comment 1 Russell Bryant 2020-01-14 16:41:05 UTC
This was resolved by https://github.com/openshift/cluster-kube-apiserver-operator/pull/712

Comment 2 Russell Bryant 2020-01-23 15:34:42 UTC
(In reply to Russell Bryant from comment #1)
> This was resolved by
> https://github.com/openshift/cluster-kube-apiserver-operator/pull/712

turns out we still need https://github.com/openshift/cluster-kube-apiserver-operator/pull/710

Comment 4 Dan Winship 2020-02-07 14:25:22 UTC
Assigning all 4.3.z IPv6 bugs to Marius Cornea for QA, as they are not yet QA-able in stock release-4.3 builds.

Comment 5 Marius Cornea 2020-02-11 21:58:04 UTC
This BZ cannot be verified for now on the 4.3-ipv6 release as the latest build(4.3.0-0.nightly-2020-02-10-055634-ipv6.3) includes a custom cluster-kube-apiserver-operator image according to https://github.com/openshift-kni/ocp-ipv6/blob/master/builds.yaml

Comment 12 errata-xmlrpc 2020-06-17 20:27:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2436


Note You need to log in before you can comment on or make changes to this bug.