Bug 178949 - command line wrapping problem in bash
command line wrapping problem in bash
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-25 12:47 EST by Hal Duston
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-26 03:45:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hal Duston 2006-01-25 12:47:10 EST
Description of problem: Commands longer than screen width don't wrap properly

Version-Release number of selected component (if applicable): bash-3.0-31

How reproducible:  Always.

Steps to Reproduce:  At a bash prompt
1.type the letter 'x' until the end of the line is reached.
2.continue typing the letter 'x'.
3.set -o vi only changes the problem from one incorrect behaviour to another 
incorrect behaviour.
 
Actual results: 
Without set -o vi:  The last character overwrites the (previous) final 
character of the line on the screen. 
With set -o vi: The line wraps around on the screen onto the same line already 
filled with the first part of the command.

Expected results: The line should continue on the line below the first one.

Additional info:  This problem does not occur with bash-3.0-18 on FC3.  I am 
ssh'd into the FC4 box from a FC3 box which is running screen.  I am ssh'd into 
the FC3 box from a W2K (5.00.2195 SP4) box which is running Putty 0.58.
Comment 1 Tim Waugh 2006-01-25 13:03:15 EST
Please paste in the output of 'set' so I can see your prompt settings.
Comment 2 Hal Duston 2006-01-25 13:10:14 EST
subset of the output of 'set' follows:

BASH=/bin/bash
BASH_ARGC=()
BASH_ARGV=()
BASH_LINENO=()
BASH_SOURCE=()
BASH_VERSINFO=([0]="3" [1]="00" [2]="16" [3]="1" [4]="release" [5]="i386-redhat-
linux-gnu")
BASH_VERSION='3.00.16(1)-release'
COLUMNS=133
HOSTTYPE=i386
IFS=$' \t\n'
INPUTRC=/etc/inputrc
LANG=en_US.UTF-8
LINES=50
MACHTYPE=i386-redhat-linux-gnu
PROMPT_COMMAND='echo -ne "\033_${USER}@${HOSTNAME%%.*}:${PWD/#$HOME/~}\033\\"'
PS1='[\u@\h \W]\$ '
PS2='> '
PS4='+ '
SHELL=/bin/bash
SHELLOPTS=braceexpand:hashall:histexpand:history:interactive-comments:monitor:vi
TERM=screen
Comment 3 Hal Duston 2006-01-25 22:18:00 EST
Additional data point:  I also see this behaviour going from SuSE 9.3 running in
Konsole ssh'd to FC3 running the same screen, ssh'd to FC4.

However . . .  I _don't_ see the behaviour going directly from the SuSE 9.3 box
to the FC4 box.

Looks like it's some kind of bizarre interaction between screen on FC3 and bash
on FC4.  If I eliminate either of those, the behaviour goes away.  screen on FC3
is screen-4.0-2.5  Now I'm not sure which to file this bugreport against.
Comment 4 Hal Duston 2006-01-25 23:34:25 EST
OK, this gets even more bizarre.  I re-did (as best as I knew) the things
leading up to this problem in another session, and it didn't happen again.  It
was still happening in the first session though.  When I backed out of
ssh+screen, and went back into it, I can't reproduce the problem.  At this point
since I cannot reliably reproduce the problem it would probably be OK to close
this bug.
Comment 5 Hal Duston 2006-01-26 10:50:23 EST
I just want to put one final comment on this.  This is most likely some kind of 
screen issue.  The session that had this problem was a long-lived screen 
session that had been attached, detached, and reattached from over many days, 
from tty's with a variety of screen sizes.  I would surmise that somehow screen 
lost track of the tty size for the window that was attached to the FC4 box.

Note You need to log in before you can comment on or make changes to this bug.