Bug 178956 - up2date takes several minutes to time-out and cannot be killed when server is unreachable
up2date takes several minutes to time-out and cannot be killed when server is...
Status: CLOSED DUPLICATE of bug 178957
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Beth Nackashi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-25 14:28 EST by Beth Nackashi
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-30 10:48:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Beth Nackashi 2006-01-25 14:28:42 EST
Description of problem:
If up2date cannot reach the host, the 'up2date' command cannot be ctrl-c'd and
it takes many minutes to come back with a response:

[root@test01-ia64 tmp]# up2date
Error communicating with server. The message was:
Connection timed out


Version-Release number of selected component (if applicable):
up2date-4.4.63-3

How reproducible:
always

Steps to Reproduce:
1- ks a client to rhel 3 u6, include @ Everything in ks profile
2- ssh -Y <client>
3- on client:  install latest up2date from
/nfs/redhat/beehive/comps/dist/3.0E-qu-candidate/
4- register the client to webqa
5- on client:  run block-host.sh script to block firstboot's connections to
webqa:   ./block-host.sh xmlrpc.rhn.webqa.redhat.com  (NOTE:  block-host.sh
needs to be loaded on the client from wherever it's stored -- maybe
/usr/local/bin locally?)  This will allow pings to the host but will prevent
udp/tcp connections.
6- run 'update' on client

  
Actual results:
'up2date' sits for many minutes.  It cannot be killed by ctrl-c.  You have to
open a new session to kill it, and even then it requires kill -9.  If you don't
kill it, it will eventually return a 'Connection timed out message.'

Expected results:
Either make up2date killable via ctrl-c or reduce the time-out period.

Additional info:
Comment 1 Beth Nackashi 2006-01-30 10:48:05 EST

*** This bug has been marked as a duplicate of 178957 ***

Note You need to log in before you can comment on or make changes to this bug.