Bug 178959 - ipw2200 module unknown notifications and firmware resets
ipw2200 module unknown notifications and firmware resets
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-25 14:39 EST by Jurgen Kramer
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 13:02:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Complete dmesg output with all ipw2200 messages over a 20 min period (21.43 KB, text/plain)
2006-01-25 14:39 EST, Jurgen Kramer
no flags Details

  None (edit)
Description Jurgen Kramer 2006-01-25 14:39:10 EST
Description of problem:
Transferrate drops or complete stalls due to firmware resets. Occasional
'unknown notification' errors

Version-Release number of selected component (if applicable):
kernel 2.6.15-1.1861 - 1863

How reproducible:
Always after generating IP traffic, say 'yum upgrade', over the wireless link.
Dmesg shows ipw2200: Firmware error detected. Restarting. Numerous times.
Transferrate drops or stalls as a result. 

Steps to Reproduce:
1. Generate some IP traffic over the wireless link
2. Transferrate drops or completely stalls
3. Check for errors with dmesg
  
Actual results:
Transferrate drops or completely stalls

Expected results:
No firmware resets, no tranferrate degradation of stalls.

Additional info:
firmware 2.4 from Sourceforge ipw2200.sf.net. Configured with 128-bit WEP.
The firmware restarts seem to be happening since ipw2200 driver > 1.01 (or
version included in FC4 kernel).

Occasional 'Unknown notification' errors look like:
ipw2200: Unknown notification: subtype=40,flags=0xa0,size=40
Comment 1 Jurgen Kramer 2006-01-25 14:39:10 EST
Created attachment 123685 [details]
Complete dmesg output with all ipw2200 messages over a 20 min period
Comment 2 Anton Keks 2006-01-28 06:26:50 EST
I have the same problem in FC4 with testing kernel 2.6.15-1.1823.
Comment 3 Anton Keks 2006-01-28 07:10:39 EST
If a download just stalls, no more connections work after that, but network
device restart helps.

Sometimes a stalled download in accompanied by the fact that ksoftirqd starts
eating 100% cpu, and this problem can only be "fixed" only by restarting the system.
Comment 4 Anton Keks 2006-02-15 14:44:49 EST
This bug shows up in FC4 with all the latest updates, so probably the version
above should be changed to 'fc4' and priority to 'high'?
Comment 5 Dave Jones 2006-02-18 21:35:16 EST
Jurgen, does the kernel from
http://people.redhat.com/davej/kernels/Fedora/devel/ fix this for you ?  John
merged a fix recently that may solve this problem, but due to the test3 freeze,
I don't think it made it to rawhide yet.

Anton, the same fix has been merged in FC4 CVS, and will go out in the next
update soon.
Comment 6 Jurgen Kramer 2006-02-20 12:20:13 EST
OK, I've tried the devel kernel from feb. 19th and used my wireless link to do a
yum update. After downloading about 650Mb over the wireless connection still no
firmware resets! So for now it seems the bug is gone.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.