Bug 1789610 - Inconsistent labels that refer to the same concept
Summary: Inconsistent labels that refer to the same concept
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.5.0
Assignee: Steve Goodwin
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-09 21:56 UTC by jintan
Modified: 2020-07-30 17:40 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:13:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
Verification screenshot (131.41 KB, image/png)
2020-05-19 03:23 UTC, XiaochuanWang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5395 0 None closed Bug 1789610: Resolve Subscribe/Install terminology when installing operator 2020-09-28 19:41:39 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:13:16 UTC

Description jintan 2020-01-09 21:56:24 UTC
Description of problem:
Inconsistent labels create confusion and delay tasks. 
“Project” vs “Namespace”, “Install” vs “Subscribe”, “Member” vs “Pod”, etc.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
To install an operator, users first select “Install” button and then have to select the “Subscribe” button on the subsequent “Create Operator Subscription” page. The same action of installing an operator was labeled as “install”, “create subscription”, or “subscribe” in the same process flow.

Actual results:
Various labels for the same action

Expected results:
Users need clarification on whether they are installing or subscribing and understand the difference. 

Additional info:

Comment 2 jintan 2020-01-21 14:26:47 UTC
Clarified OCP version 4.3.0

Comment 3 Steve Goodwin 2020-01-27 22:55:06 UTC
The UI development team will need input from UX team, as to appropriate names/labels and wording that should be used in the specific user scenarios noted above.

Comment 4 Peter Kreuser 2020-02-20 15:37:30 UTC
I am changing the scope of this bug to just be the resolution of the "Install" & "Subscribe" terminology, as this would be the most specific to the operator installation area. I have captured this in design story [https://issues.redhat.com/browse/PD-377] and will work towards a design that more consistently uses these terms. I will link that design in this bug once complete.

I have captured the more widespread issue of project/namespace usage in design story: https://issues.redhat.com/browse/PD-422

I suspect the use of "member" instead of pod was specific to the etcd operator, and would require a change on the operator's part.

Comment 5 Peter Kreuser 2020-02-21 17:45:52 UTC
The updated design can be seen attached to https://issues.redhat.com/browse/PD-377

On the operator installation page:

Operator Subscription -> Operator Installation

Create Operator Subscription -> Install Operator

Subscribe (button) -> Install

Also the website page title: OperatorHub Subscription -> Operator Installation

Comment 6 Steve Goodwin 2020-05-11 18:55:23 UTC
https://github.com/openshift/console/pull/5395

Comment 10 XiaochuanWang 2020-05-19 03:23:50 UTC
Created attachment 1689736 [details]
Verification screenshot

Comment 11 XiaochuanWang 2020-05-19 03:24:41 UTC
Display correctly, attached the screenshot for refer.
Verified on 4.5.0-0.nightly-2020-05-19-011623

Comment 13 errata-xmlrpc 2020-07-13 17:13:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.