Bug 178967 - Future of lam - use alternatives
Future of lam - use alternatives
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lam (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Brian Brock
: FutureFeature
Depends On:
Blocks: 181573
  Show dependency treegraph
 
Reported: 2006-01-25 15:40 EST by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: lam-7.1.1-11
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-05 14:06:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to lam.spec to add support for alternatives (2.23 KB, patch)
2006-01-25 15:40 EST, Orion Poplawski
no flags Details | Diff
Patch to lam.spec to add support for alternatives (2.30 KB, patch)
2006-01-26 18:59 EST, Orion Poplawski
no flags Details | Diff

  None (edit)
Description Orion Poplawski 2006-01-25 15:40:37 EST
Created attachment 123687 [details]
Patch to lam.spec to add support for alternatives
Comment 1 Orion Poplawski 2006-01-25 15:40:37 EST
Description of problem:

As discussed in the thread started here: 

https://www.redhat.com/archives/fedora-devel-list/2006-January/msg00064.html

LAM-MPI is at the end of the road.  openmpi looks like the logical replacement,
and it would be desirable for mpich2 to be able to be installed alongside either
(or both).

So, what to do?  Possibilities:

- In any case, make all (lam, openmpi, mpich2,...) use alternatives system
- replace lam with openmpi in core
- keep lam in core, add openmpi and mpich2 in extras

So, attached is a patch to the lam spec which should allow it to co-exist with
openmpi and mpich2 via alternatives.  It's probably just a start.  We probably
also need to think about how to handle /usr/include/mpi{f}.h and
/usr/lib/libmpi.*.  

It would be fantastic if we could get this in place for FC5.
Comment 2 Deji Akingunola 2006-01-25 22:24:08 EST
Hi Orion,

It's great you're doing this. For completeness sake, alternatives have to be
created for the man files too for lam to coexists with both mpich(1) and mpich2.
Comment 3 Orion Poplawski 2006-01-26 18:59:06 EST
Created attachment 123757 [details]
Patch to lam.spec to add support for alternatives

Here's an update that fixes some obvious errors.

As mentioned by Deji, we still need to handle the man pages.  The command man
pages aren't bad.  What looks like trouble is the ~270 API man(3) pages that
conflict with mpich (and possible openmpi sometime in the future).
Comment 4 Jason Vas Dias 2006-02-23 13:41:59 EST
This bug is now fixed with lam-7.1.1-11 in FC-5 - see bug 173619 .
Comment 5 Jason Vas Dias 2006-02-23 13:43:17 EST
Oops, should have been 'see bug 173719' .

Note You need to log in before you can comment on or make changes to this bug.