Bug 178976 - rpm segmentation fault when updating rpm-4.4.1-22.x86_64.rpm
rpm segmentation fault when updating rpm-4.4.1-22.x86_64.rpm
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-25 16:37 EST by Scott Koranda
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-27 11:03:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output on seg faulting rpm command (151.63 KB, text/plain)
2006-01-25 16:50 EST, Scott Koranda
no flags Details

  None (edit)
Description Scott Koranda 2006-01-25 16:37:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
[root@moon ~]# ls -l rpm-4.4.1-22.x86_64.rpm 
-rw-r--r--  1 root root 596341 Jul 13  2005 rpm-4.4.1-22.x86_64.rpm
[root@moon ~]# md5sum rpm-4.4.1-22.x86_64.rpm 
37b01382694ac79ce43ab8308cd789cf  rpm-4.4.1-22.x86_64.rpm
[root@moon ~]# rpm -vv -Uh rpm-4.4.1-22.x86_64.rpm 
D: ============== rpm-4.4.1-22.x86_64.rpm
D: Expected size:       596341 = lead(96)+sigs(344)+pad(0)+data(595901)
D:   Actual size:       596341
D: opening  db environment /var/lib/rpm/Packages joinenv
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: locked   db index       /var/lib/rpm/Packages
D: opening  db index       /var/lib/rpm/Pubkeys rdonly mode=0x0
D:  read h#     812 Header sanity check: OK
D: ========== DSA pubkey id b44269d0 4f2a6fd2 (h#812)
D: rpm-4.4.1-22.x86_64.rpm: Header V3 DSA signature: OK, key ID 4f2a6fd2
Segmentation fault


Version-Release number of selected component (if applicable):
rpm-4.4.1-21

How reproducible:
Always

Steps to Reproduce:
1. See submitted description.
2.
3.
  

Additional info:
Comment 1 Scott Koranda 2006-01-25 16:50:41 EST
Created attachment 123694 [details]
strace output on seg faulting rpm command

Output from the command

strace rpm -vv -Uh rpm-4.4.1-22.x86_64.rpm >& strace.out
Comment 2 Scott Koranda 2006-01-25 17:04:22 EST
gdb shows this stack at the time of the seg fault:

(gdb) bt
#0  0x00002aaaaac08008 in rpmfiFree () from /usr/lib64/librpm-4.4.so
#1  0x00002aaaaac0a090 in rpmfiNew () from /usr/lib64/librpm-4.4.so
#2  0x00002aaaaac150b1 in rpmteNew () from /usr/lib64/librpm-4.4.so
#3  0x00002aaaaabeb18a in rpmtsAddInstallElement ()
   from /usr/lib64/librpm-4.4.so
#4  0x00002aaaaac0d5da in rpmInstall () from /usr/lib64/librpm-4.4.so
#5  0x000000000040499d in ?? ()
#6  0x00000032f141c4cc in __libc_start_main () from /lib64/libc.so.6
#7  0x00000000004039a9 in ?? ()
#8  0x00007fffff8f0818 in ?? ()
#9  0x0000000000000000 in ?? ()
Comment 3 Jeff Johnson 2006-01-26 17:20:32 EST
Does the problem reproduce with rpm-4.4.4 packages from
    http://wraptastic.org/pub/x86_64-CentOS4-linux/RPMS/{rpm,popt}-*
Comment 4 Scott Koranda 2006-01-27 11:03:24 EST
My apologies. It looks like there are substantial problems with the system as
other programs not related to PRM are now seg faulting.

Please consider this not a bug and let it be close.

Note You need to log in before you can comment on or make changes to this bug.