Bug 179001 - Release notes in anaconda uses unreadable font
Release notes in anaconda uses unreadable font
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-26 07:25 EST by Richard Hughes
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-26 11:38:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Hughes 2006-01-26 07:25:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Using rawhide anaconda on my ppc iBook (800x600 screen) I click "Release Notes" and the window pops up in the top half of the screen. So far, so good.

The font used does not however match any of the anaconda fonts, is not antialiased, and is very difficult to read.

This should probably be the same font that is used elsewhere in the installer, as the font that is used now looks very out of place in an otherwise very slick and professional installer.



Version-Release number of selected component (if applicable):
anaconda-10.91.7-1

How reproducible:
Always

Steps to Reproduce:
1. Install fc rawhide with ananconda
2. Click release notes
3. Recoil in horror at font being used


Actual Results:  Had to squint at the screen to read the text.

Expected Results:  Text should be the same font as used elsewhere in the installer, antialiased and easy to read.

Additional info:
Comment 1 David Cantrell 2006-01-26 11:38:43 EST
Regarding the actual display of the text in the release notes.... we use a
GtkHtml widget of some sort.  The reason for this is we prefer to open the HTML
version of the release notes.  If we don't find those, we default to opening the
text version.  Failing that, we just say we can't find the release notes.  If we
open the text version, we wrap it in HTML pre tags and slap that in the HTML
window.  The scrollbar is automatic based on the text you feed the widget.
That's why it looks bad.  Final releases of Fedora Core usually come with HTML
versions of the release notes.

(Copied from bug #163297 which referenced this same issue).
Comment 2 Richard Hughes 2006-01-26 12:36:44 EST
Ohh, okay, many thanks for clearing that one up for me.
Comment 3 Bill Nottingham 2006-02-07 13:21:04 EST
But, why does the text make it use an ugly font? Are the default gtkhtml fonts
that bad?
Comment 4 David Cantrell 2006-02-07 13:32:12 EST
The non-HTML release notes are UTF-8 text files, so whatever that's causing the
gtkhtml widget to do.  If there's another font we can use, I suppose we can just
copy that to the image.  I'll see about that.
Comment 5 Richard Hughes 2006-02-07 13:52:23 EST
It's some type of scripted font that is not-antialiased and pretty horrible to
read. I'm sure you could just change the default font for the gtkhtml widget
quite easily. Thanks for looking into this btw.

Note You need to log in before you can comment on or make changes to this bug.