Due to a recent update on Javascript code a full page refresh on your browser might be needed.
Bug 1790093 - disk driver with iothread setting hangs live migrations
Summary: disk driver with iothread setting hangs live migrations
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-11 18:41 UTC by Mark Zealey
Modified: 2020-01-13 08:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-13 08:04:24 UTC


Attachments (Terms of Use)

Description Mark Zealey 2020-01-11 18:41:54 UTC
Description of problem:

A disk driver definition using iothread parameter causes live migration with copy storage to hang during or just before the final ram sync stage.

Interestingly, having the scsi controller as a separate iothread does not trigger the issue.

Version-Release number of selected component (if applicable):

I can reproduce this on centos7 with qemu-ev and with centos 8:

qemu-kvm-ev-2.12.0-33.1.el7_7.4.x86_64
qemu-kvm-2.12.0-65.module_el8.0.0+189+f9babebb.5.x86_64


How reproducible:

Always


Steps to Reproduce:
1. Create a definition with 1 iothread on the disk image:

      <driver name='qemu' type='qcow2' iothread='1' />

2. Issue a live migrate request like: virsh migrate --live --copy-storage-all vm qemu+tcp://remote/system
3. Live migrate on source copies storage and then hangs at 80-99%, I guess during the ram copy phase.

Keeping exactly the same config but without the iothread on the disk driver has successful migrations every time.


Additional info:

Comment 1 Peter Krempa 2020-01-13 08:04:24 UTC
There are few problems with iothreads and block jobs being solved in qemu upstream.

https://lists.gnu.org/archive/html/qemu-devel/2020-01/msg01440.html

Unfortunately the QEMU upstream bug tracking is not handled in this bugzilla instance but at

https://bugs.launchpad.net/qemu/

I will close this bug since I can't move it to qemu. Please report it to the qemu team.


Note You need to log in before you can comment on or make changes to this bug.