Bug 179019 - gdm face browser crashes with user list
gdm face browser crashes with user list
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-26 12:02 EST by Wart
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-09 02:11:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wart 2006-01-26 12:02:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
The "Happy Gnome w/ Browser" gdm theme with users in the include list (either a single user or "all users") causese gdm to crash when it is restarted. 

Version-Release number of selected component (if applicable):
2.13.0.4-2 and 2.13.0.5-7

How reproducible:
Always

Steps to Reproduce:
1. Install FC5-test2 with the default package selection
2. Log in to gnome as root (or as a user then su to root) and run gdmsetup
3. Change the gdm theme to "Happy Gnome w/ Browser"
4. Click on the "Users" tab and select "Include all users...", or manually enter the non-root user created during firstboot
5. Press "Close" to save and apply the changes
6. Logout
  

Actual Results:  The user is logged out and gdm fails to restart.  After 6 failures the text console presents a warning dialog that "The display server has been shut down 6 times in the past 90 seconds.  It is likely that something bad is going on.  Waiting for 2 minutes before trying again on display :0"

Expected Results:  The new gdm theme with the face browser appears.

Additional info:

This happens in both FC5-test2 and FC5-test2 with the latest updates.  I do not see this problem on my FC4 box.  It doesn't appear to be an X problem because rhgb runs fine.  This only seems to happen when I use both the Happy Gnome w/ Browser theme and a user list.  If I use only one of the two then it works fine.  The problem still appears even after a reboot.

FWIW, I'm running this in a VMWare virtual machine.
Comment 1 Marius Andreiana 2006-02-16 14:45:22 EST
This works on current rawhide, would you please test again?
Comment 2 Rahul Sundaram 2006-02-20 05:52:20 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 3 Marius Andreiana 2006-04-09 02:11:31 EDT
Closing after receiving no reply in 2 months. Worksforme in FC5

Note You need to log in before you can comment on or make changes to this bug.